Efficient JS File API - JavaScript module

RESOLVED WONTFIX

Status

()

Core
Networking: File
--
enhancement
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: Yoric, Assigned: Yoric)

Tracking

({main-thread-io, perf})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

Implement the JavaScript front-end for the JS File API as a JS module.

This front-end should:
- offer all the features of the back-end;
- be developer-friendly;
- work from any thread;
- expose or work nicely with a concurrent and/or asynchronous API.
Depends on: 707676
No longer depends on: 707096
Created attachment 579097 [details] [diff] [review]
Prev 2. JavaScript Module front-end

Second preview of the module. Large refactoring for a better API.
Depends on: 692424
Component: JavaScript Engine → Networking: File
QA Contact: general → networking.file
Created attachment 580350 [details] [diff] [review]
Prev 3.

New version of the patch. Implements main thread warning and some asynchronous functions.
Attachment #579097 - Attachment is obsolete: true
Created attachment 580861 [details] [diff] [review]
Prev 4. First steps of asynchronous API

Attaching a new version with the first steps of an asynchronous API.

For the time being, I intend to provide simple (possibly placeholder) implementation of asynchronous stuff. Once we are in a situation where we can benchmark, future versions may introduce multi-threading and/or OS-accelerated asynchronous operations.
Attachment #580350 - Attachment is obsolete: true
Attachment #580861 - Flags: review?(dherman)
Created attachment 580862 [details] [diff] [review]
Prev 4. Test suite

Companion testsuite
Duplicate of this bug: 707910
Comment on attachment 580861 [details] [diff] [review]
Prev 4. First steps of asynchronous API

i'm not the right person to review; I'd ask one of the module owners of toolkit:

https://wiki.mozilla.org/Modules/Toolkit

Dave
Attachment #580861 - Flags: review?(dherman)
Strategy has changed completely. Marking this bug as WONTFIX and opening a new one.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.