Last Comment Bug 707682 - java.lang.NullPointerException @ Tabs.isSelectedTab(Tabs.java:117)
: java.lang.NullPointerException @ Tabs.isSelectedTab(Tabs.java:117)
Status: VERIFIED FIXED
[native-crash]
: crash, regression, reproducible
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P3 critical (vote)
: ---
Assigned To: Sriram Ramasubramanian [:sriram]
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on: 701884
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-05 07:40 PST by Aaron Train [:aaronmt]
Modified: 2012-01-27 04:51 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
Patch (2.24 KB, patch)
2011-12-06 14:56 PST, Sriram Ramasubramanian [:sriram]
mark.finkle: review+
Details | Diff | Splinter Review

Description Aaron Train [:aaronmt] 2011-12-05 07:40:38 PST
I/GeckoApp( 2871): Got message: Tab:Closed
I/GeckoApp( 2871): Destroyed a tab
I/GeckoTabs( 2871): Removed a tab with id: 2
D/GeckoInputConnection( 2871): IME: run()
D/GeckoInputConnection( 2871): IME: v=org.mozilla.gecko.gfx.LayerView@4058de60
I/GeckoDoorHangerPopup( 2871): Showing all doorhangers for tab: 1
I/GeckoDoorHangerPopup( 2871): Showing all doorhangers for tab: 1
E/GeckoApp( 2871): top level exception
E/GeckoApp( 2871): java.lang.NullPointerException
E/GeckoApp( 2871): 	at org.mozilla.gecko.Tabs.isSelectedTab(Tabs.java:117)
E/GeckoApp( 2871): 	at org.mozilla.gecko.TabsTray$TabsAdapter$2.onClick(TabsTray.java:184)
E/GeckoApp( 2871): 	at android.view.View.performClick(View.java:2485)
E/GeckoApp( 2871): 	at android.view.View$PerformClick.run(View.java:9080)
E/GeckoApp( 2871): 	at android.os.Handler.handleCallback(Handler.java:587)
E/GeckoApp( 2871): 	at android.os.Handler.dispatchMessage(Handler.java:92)
E/GeckoApp( 2871): 	at android.os.Looper.loop(Looper.java:130)
E/GeckoApp( 2871): 	at org.mozilla.gecko.GeckoApp$26.run(GeckoApp.java:1342)
E/GeckoApp( 2871): 	at android.os.Handler.handleCallback(Handler.java:587)
E/GeckoApp( 2871): 	at android.os.Handler.dispatchMessage(Handler.java:92)
E/GeckoApp( 2871): 	at android.os.Looper.loop(Looper.java:130)
E/GeckoApp( 2871): 	at android.app.ActivityThread.main(ActivityThread.java:3683)
E/GeckoApp( 2871): 	at java.lang.reflect.Method.invokeNative(Native Method)
E/GeckoApp( 2871): 	at java.lang.reflect.Method.invoke(Method.java:507)
E/GeckoApp( 2871): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:839)
E/GeckoApp( 2871): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:597)
E/GeckoApp( 2871): 	at dalvik.system.NativeStart.main(Native Method)
D/Zygote  ( 2378): Process 2871 exited cleanly (1)
I/WindowManager( 2385): WIN DEATH: Window{4086ee10 org.mozilla.fennec/org.mozilla.fennec.App paused=false}
I/ActivityManager( 2385): Process org.mozilla.fennec (pid 2871) has died.
I/WindowManager( 2385): WIN DEATH: Window{40888118 SurfaceView paused=false}

STR:

1. http://espn.com, http://m.engadget.com
2. Switch between tabs, and then close the first tab

--
Samsung Galaxy SII (Android 2.3.4)
20111205040214
http://hg.mozilla.org/projects/birch/rev/85e665cc4a97
Comment 1 Sriram Ramasubramanian [:sriram] 2011-12-06 14:56:23 PST
Created attachment 579469 [details] [diff] [review]
Patch

Unfortunately, I couldn't reproduce the bug as always.
However, I've added a preventive check to avoid an NPE.
Also, I've cleaned up some code.
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-08 13:52:04 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/bb4d6dffb53d
Comment 3 Ed Morley [:emorley] 2011-12-09 06:54:27 PST
https://hg.mozilla.org/mozilla-central/rev/bb4d6dffb53d
Comment 4 Cristian Nicolae (:xti) 2012-01-27 04:51:11 PST
This crash cannot be reproduced anymore on the latest Nightly build. Closing bug as verified fixed. Please file a new bug if this crash will occur again.

--
Mozilla/5.0 (Android;Linux armv7l;rv:12.0a1)Gecko/2012012
Firefox/12.0a1 Fennec/12.0a1
Device: Samsung Nexus S
OS: Android 2.3.6

Note You need to log in before you can comment on or make changes to this bug.