Intermittent REFTEST TEST-UNEXPECTED-FAIL | layout/reftests/svg/smil/container/deferred-anim-1.xhtml | image comparison (==)

RESOLVED FIXED in Firefox 15

Status

()

defect
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: mbrubeck, Assigned: birtles)

Tracking

({intermittent-failure})

Trunk
mozilla16
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox15 fixed)

Details

Attachments

(2 attachments)

Reporter

Description

8 years ago
In image 1, the blue square is slightly left of center.  In image 2 it is slightly right of center.

https://tbpl.mozilla.org/php/getParsedLog.php?id=7751085&tree=Mozilla-Inbound
REFTEST INFO | Loading a blank page
REFTEST TEST-START | http://10.250.48.211:30088/tests/layout/reftests/svg/smil/container/moved-tree-1.xhtml | 955 / 2398 (39%)
REFTEST TEST-START | http://10.250.48.211:30088/tests/layout/reftests/svg/smil/container/moved-tree-1-ref.xhtml | 955 / 2398 (39%)
REFTEST TEST-KNOWN-FAIL(EXPECTED RANDOM) | http://10.250.48.211:30088/tests/layout/reftests/svg/smil/container/moved-tree-1.xhtml | image comparison (==) 
REFTEST INFO | Loading a blank page
REFTEST TEST-START | http://10.250.48.211:30088/tests/layout/reftests/svg/smil/container/deferred-anim-1.xhtml | 956 / 2398 (39%)
REFTEST TEST-START | http://10.250.48.211:30088/tests/layout/reftests/svg/smil/container/deferred-anim-1-ref.xhtml | 956 / 2398 (39%)
REFTEST TEST-UNEXPECTED-FAIL | http://10.250.48.211:30088/tests/layout/reftests/svg/smil/container/deferred-anim-1.xhtml | image comparison (==) 
REFTEST   IMAGE 1 (TEST): [...]before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
before 385024, after 385024, break 057ff000
[...]
REFTEST   IMAGE 2 (REFERENCE): [...]
REFTEST number of differing pixels: 3188
REFTEST INFO | Saved log: START http://10.250.48.211:30088/tests/layout/reftests/svg/smil/container/deferred-anim-1.xhtml
REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering WaitForTestEnd
REFTEST INFO | Saved log: [CONTENT] WaitForTestEnd: Adding listeners
REFTEST INFO | Saved log: Initializing canvas snapshot
REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for MozAfterPaint
REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in http://10.250.48.211:30088/tests/layout/reftests/svg/smil/container/deferred-anim-1.xhtml
REFTEST INFO | Saved log: Updating canvas for invalidation
REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
REFTEST INFO | Saved log: [CONTENT] AttrModifiedListener fired
REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in http://10.250.48.211:30088/tests/layout/reftests/svg/smil/container/deferred-anim-1.xhtml
REFTEST INFO | Saved log: Updating canvas for invalidation
REFTEST INFO | Saved log: DoDrawWindow 34,87,69,42
REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
REFTEST INFO | Saved log: [CONTENT] MakeProgress: dispatching MozReftestInvalidate
REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FINISH
REFTEST INFO | Saved log: [CONTENT] MakeProgress: Completed
REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_COMPLETED
REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_COMPLETED
REFTEST INFO | Saved log: [CONTENT] RecordResult fired
REFTEST INFO | Saved log: RecordResult fired
REFTEST INFO | Saved log: START http://10.250.48.211:30088/tests/layout/reftests/svg/smil/container/deferred-anim-1-ref.xhtml
REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering AfterOnLoadScripts
REFTEST INFO | Saved log: Initializing canvas snapshot
REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
REFTEST INFO | Saved log: [CONTENT] RecordResult fired
REFTEST INFO | Saved log: RecordResult fired
REFTEST INFO | Loading a blank page
REFTEST TEST-START | http://10.250.48.211:30088/tests/layout/reftests/svg/smil/container/deferred-tree-1.xhtml | 957 / 2398 (39%)
REFTEST TEST-START | http://10.250.48.211:30088/tests/layout/reftests/svg/smil/container/deferred-tree-1-ref.xhtml | 957 / 2398 (39%)
REFTEST TEST-PASS | http://10.250.48.211:30088/tests/layout/reftests/svg/smil/container/deferred-tree-1.xhtml | image comparison (==) 
REFTEST INFO | Loading a blank page
Whiteboard: [android_tier_1][orange] → [orange]
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Removing "Android" from the summary, as this happened on WinXP as well (see comment 3) - I'm assuming it's really the same issue.
OS: Android → All
Hardware: ARM → All
Summary: Intermittent Android REFTEST TEST-UNEXPECTED-FAIL | layout/reftests/svg/smil/container/deferred-anim-1.xhtml | image comparison (==) → Intermittent REFTEST TEST-UNEXPECTED-FAIL | layout/reftests/svg/smil/container/deferred-anim-1.xhtml | image comparison (==)
Version: 11 Branch → Trunk
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Updated

7 years ago
Assignee: nobody → birtles
Status: NEW → ASSIGNED
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Comment 70

7 years ago
Attachment #640834 - Flags: review?(dholbert)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment on attachment 640834 [details] [diff] [review]
Proposed fix v1a

Looks good! Just one nit:

>+          timeoutID = window.setTimeout(giveUp, 30000);
[...]
>+
>+        function giveUp() {
>+          var svg = document.getElementsByTagName('svg')[0];
>+          var rect = svg.getElementsByTagName('rect')[0];
>+          rect.setAttribute("fill", "red");
>+          finish();
>+        }
>+
>+        function finish() {
>+          if (timeoutID) {
>+            window.clearTimeout(timeoutID);
>+            timeoutID = null;
>+          }

So -- giveUp() probably wants to set timeoutID = null before it calls finish(), right?  Since there's no point in calling clearTimeout on for a timeout that's already fired?

(I imagine that's what you intended -- otherwise, there'd be no reason to null-check timeoutID in finish(), since I think it's currently always going to be set at that point.)

r=me with that fixed.  Thanks!
Attachment #640834 - Flags: review?(dholbert) → review+
Assignee

Comment 73

7 years ago
Thanks Daniel, that's great.

I took the chance to fix the same bit of code in deferred-tree-1.xhtml at the same time plus a few other tweaks:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f16647509237
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
https://hg.mozilla.org/mozilla-central/rev/f16647509237
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla16
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment on attachment 640834 [details] [diff] [review]
Proposed fix v1a

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Unknown
User impact if declined: Higher rate of [orange]
Testing completed (on m-c, etc.): m-c, aurora
Risk to taking this patch (and alternatives if risky): N/A, test-only fix.
String or UUID changes made by this patch: None
Attachment #640834 - Flags: approval-mozilla-beta?
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Attachment #640834 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.