Last Comment Bug 707882 - Xulrunner make deb fail, rm xpidl
: Xulrunner make deb fail, rm xpidl
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: mozilla11
Assigned To: Oleg Romashin (:romaxa)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-05 21:55 PST by Oleg Romashin (:romaxa)
Modified: 2011-12-08 08:54 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Xulrunner debian packaging (3.27 KB, patch)
2011-12-05 22:19 PST, Oleg Romashin (:romaxa)
no flags Details | Diff | Review
Xulrunner debian packaging (5.27 KB, patch)
2011-12-05 22:26 PST, Oleg Romashin (:romaxa)
no flags Details | Diff | Review
Xulrunner debian packaging fixes (5.38 KB, patch)
2011-12-06 10:51 PST, Oleg Romashin (:romaxa)
benjamin: review+
Details | Diff | Review

Description Oleg Romashin (:romaxa) 2011-12-05 21:55:47 PST
xpidl seems not anymore in xulrunner, but xulrunner installer trying to package it and failing.
Comment 1 Oleg Romashin (:romaxa) 2011-12-05 22:14:56 PST
also it make sense to fix shlibdeps... because now it just hardcoded
Comment 2 Oleg Romashin (:romaxa) 2011-12-05 22:19:29 PST
Created attachment 579234 [details] [diff] [review]
Xulrunner debian packaging

remove xpidl, disable generate cache on scratchbox (maemo), and use shlibdeps...
Need it for building xulrunner as engine for IPC embedding
Comment 3 Oleg Romashin (:romaxa) 2011-12-05 22:26:44 PST
Created attachment 579237 [details] [diff] [review]
Xulrunner debian packaging

one more thin, disable gtk stuff on non-gtk build
Comment 4 Oleg Romashin (:romaxa) 2011-12-06 10:51:36 PST
Created attachment 579376 [details] [diff] [review]
Xulrunner debian packaging fixes

Added literal hook, in order to avoid #!/bin/sh strip from postinst prerm files
Comment 5 Ed Morley [:emorley] 2011-12-08 08:54:27 PST
https://hg.mozilla.org/mozilla-central/rev/66a2ddade3f0

Note You need to log in before you can comment on or make changes to this bug.