Last Comment Bug 707929 - java.lang.NullPointerException @ ZipFile.getInputStream(ZipFile.java:256)
: java.lang.NullPointerException @ ZipFile.getInputStream(ZipFile.java:256)
Status: RESOLVED FIXED
[native-crash]
: crash
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P3 critical (vote)
: ---
Assigned To: Brad Lassey [:blassey] (use needinfo?)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-06 07:29 PST by Aaron Train [:aaronmt]
Modified: 2012-01-09 10:16 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
patch (1.34 KB, patch)
2011-12-13 14:17 PST, Brad Lassey [:blassey] (use needinfo?)
mark.finkle: review+
Details | Diff | Splinter Review

Description Aaron Train [:aaronmt] 2011-12-06 07:29:46 PST
I/GeckoAddons(  800): java.lang.NullPointerException
I/GeckoAddons(  800): 	at java.util.zip.ZipFile.getInputStream(ZipFile.java:256)
I/GeckoAddons(  800): 	at org.mozilla.gecko.AboutHomeContent.getRecommendedAddonsStream(AboutHomeContent.java:177)
I/GeckoAddons(  800): 	at org.mozilla.gecko.AboutHomeContent$4.run(AboutHomeContent.java:185)
I/GeckoAddons(  800): 	at android.os.Handler.handleCallback(Handler.java:587)
I/GeckoAddons(  800): 	at android.os.Handler.dispatchMessage(Handler.java:92)
I/GeckoAddons(  800): 	at android.os.Looper.loop(Looper.java:130)
I/GeckoAddons(  800): 	at org.mozilla.gecko.GeckoAppShell$LooperThread.run(GeckoAppShell.java:153)

On launch crash with:

20111206040208
http://hg.mozilla.org/projects/birch/rev/a7fb88bd5148
Comment 1 Brad Lassey [:blassey] (use needinfo?) 2011-12-13 14:10:13 PST
(In reply to Aaron Train [:aaronmt] from comment #0)
> I/GeckoAddons(  800): java.lang.NullPointerException
> I/GeckoAddons(  800): 	at
> java.util.zip.ZipFile.getInputStream(ZipFile.java:256)
> I/GeckoAddons(  800): 	at
> org.mozilla.gecko.AboutHomeContent.
> getRecommendedAddonsStream(AboutHomeContent.java:177)
> I/GeckoAddons(  800): 	at
> org.mozilla.gecko.AboutHomeContent$4.run(AboutHomeContent.java:185)
> I/GeckoAddons(  800): 	at android.os.Handler.handleCallback(Handler.java:587)
> I/GeckoAddons(  800): 	at android.os.Handler.dispatchMessage(Handler.java:92)
> I/GeckoAddons(  800): 	at android.os.Looper.loop(Looper.java:130)
> I/GeckoAddons(  800): 	at
> org.mozilla.gecko.GeckoAppShell$LooperThread.run(GeckoAppShell.java:153)
> 
> On launch crash with:
> 
> 20111206040208
> http://hg.mozilla.org/projects/birch/rev/a7fb88bd5148

how is this a crash? It is inside a blanket try-catch. If you are actually crashing, this is not the reason, so please attach a bigger log.
Comment 2 Aaron Train [:aaronmt] 2011-12-13 14:11:39 PST
I don't see this anymore.
Comment 3 Brad Lassey [:blassey] (use needinfo?) 2011-12-13 14:17:52 PST
Created attachment 581429 [details] [diff] [review]
patch

even though this is not a crash, I do not like throwing unnecessarily, so here are some null checks
Comment 4 Brad Lassey [:blassey] (use needinfo?) 2011-12-13 14:58:03 PST
pushed https://hg.mozilla.org/mozilla-central/rev/1f03a95b661a

Note You need to log in before you can comment on or make changes to this bug.