Mochitest leaks involving nsHostResolver and nsHostRecord when network is busted

RESOLVED DUPLICATE of bug 706517

Status

()

defect
RESOLVED DUPLICATE of bug 706517
8 years ago
6 years ago

People

(Reporter: mak, Assigned: sworkman)

Tracking

({intermittent-failure, memory-leak})

Firefox Tracking Flags

(Not tracked)

Details

During today network bustage a bunch of mochitests turned orange on a leak involving nsHostResolver and nsHostRecord. This happened across different trees at the same time.
So maybe with some network error condition we are not correctly freeing up resources?

As a side note, but not sure if related, lately some of us (at least me and edmorley) hit a bug where after lading a bunch of not-responding or slow-to-reply mozilla pages, put Firefox into a load-nothing state. I was able to fix it by restarting it, while Ed had to switch to another browser for a while. This looks like a recent regression. I may file it apart if you think it's unrelated.

== BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, default process 2218

     |<----------------Class--------------->|<-----Bytes------>|<----------------Objects---------------->|<--------------References-------------->|
                                              Per-Inst   Leaked    Total      Rem      Mean       StdDev     Total      Rem      Mean       StdDev
   0 TOTAL                                          18      448 203852739        6 (18307.24 +/- 35542.51) 136436806        2 (43265.29 +/- 80872.28)
  40 CondVar                                        32       32     7483        1 (   12.64 +/-     1.00)        0        0 (    0.00 +/-     0.00)
 131 Mutex                                          24       48    31973        2 (  121.44 +/-    30.41)        0        0 (    0.00 +/-     0.00)
 691 nsHostRecord                                  128      128       15        1 (    7.76 +/-     4.26)    11169        1 (   13.16 +/-    16.53)
 692 nsHostResolver                                232      232        2        1 (    0.67 +/-     0.58)    12327        1 (   19.79 +/-    32.57)
1000 nsTArray_base                                   8        8 35838286        1 (85138.87 +/- 26377.23)        0        0 (    0.00 +/-     0.00)

nsTraceRefcntImpl::DumpStatistics: 1162 entries
TEST-PASS | automationutils.processLeakLog() | no leaks detected!
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 448 bytes during test execution
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of CondVar with size 32 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 2 instances of Mutex with size 24 bytes each (48 bytes total)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of nsHostRecord with size 128 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of nsHostResolver with size 232 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of nsTArray_base with size 8 bytes
https://tbpl.mozilla.org/php/getParsedLog.php?id=7771497&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=7771428&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=7771361&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=7771402&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=7771351&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=7771624&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=7771995&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=7771815&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=7771786&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=7771755&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=7772018&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=7771846&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=7771803&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=7772042&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=7772165&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=7769665&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=7771401&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=7771256&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=7771236&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=7771243&tree=Mozilla-Inbound
I think its just a timer race condition of the test and maybe a shutdown cleanup problem.. I'm 99% sure there is no accumulating leak when lookups just don't come back. there is a timer for that (because we need to inform the http code it isn't going to work) but I bet it hadn't fired yet when the test shutdown.

maybe steve can confirm and/or fix the shutdown issue.
Assignee: nobody → sjhworkman
Added to my todo list :)
Looks like this is a dup of bug 706517.  More comments in that bug.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 706517
Keywords: mlk
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.