Last Comment Bug 708065 - Fix configure check for -pipe
: Fix configure check for -pipe
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla11
Assigned To: Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-06 13:03 PST by Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
Modified: 2011-12-09 06:54 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix configure check for -pipe (2.09 KB, patch)
2011-12-06 13:08 PST, Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
ted: review+
Details | Diff | Splinter Review

Description Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2011-12-06 13:03:20 PST
With the shell used on OS X, the test we are trying to compile is

#include <stdio.h>
int main() { printf("Hello World
"); exit(0); }

which fails. Since the newline is not important for the test, we can just remove it. Note the 

checking for gcc -pipe support... no

in 

https://tbpl.mozilla.org/php/getParsedLog.php?id=7775554&tree=Try&full=1
Comment 1 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2011-12-06 13:08:24 PST
Created attachment 579427 [details] [diff] [review]
Fix configure check for -pipe

https://tbpl.mozilla.org/?tree=Try&rev=4916ff7a83cf
Comment 2 Ted Mielczarek [:ted.mielczarek] 2011-12-06 14:53:28 PST
Comment on attachment 579427 [details] [diff] [review]
Fix configure check for -pipe

Review of attachment 579427 [details] [diff] [review]:
-----------------------------------------------------------------

Silly. When did -pipe get added to GCC anyway? We might be able to just drop this check and use it without checking at this point.
Comment 3 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2011-12-08 13:56:05 PST
Good question. Looks like it was added to trunk in r60174 back in Dec 16 2002! I am not sure if all the tier2 and tier3 compilers take this option, but we can probably at least simplify the test.

I will push this to fix the immediate problem and open a new bug if needed.
Comment 4 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2011-12-08 14:03:11 PST
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=b583dad40c36
Comment 5 Ed Morley [:emorley] 2011-12-09 06:54:14 PST
https://hg.mozilla.org/mozilla-central/rev/b583dad40c36

Note You need to log in before you can comment on or make changes to this bug.