Last Comment Bug 708072 - (test-stretchy) Test page for stretchy and large operators
(test-stretchy)
: Test page for stretchy and large operators
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: MathML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla12
Assigned To: Frédéric Wang (:fredw)
:
Mentors:
Depends on:
Blocks: 755541
  Show dependency treegraph
 
Reported: 2011-12-06 13:24 PST by Frédéric Wang (:fredw)
Modified: 2012-05-15 15:07 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (21.36 KB, patch)
2011-12-06 13:24 PST, Frédéric Wang (:fredw)
karlt: review+
Details | Diff | Splinter Review
Test stretchy and large operators (88.73 KB, text/html)
2011-12-06 13:25 PST, Frédéric Wang (:fredw)
no flags Details

Description Frédéric Wang (:fredw) 2011-12-06 13:24:32 PST
Created attachment 579433 [details] [diff] [review]
Patch

I open this bug to create a test generated from our operator dictionary, for verifying stretchy and large operators.

Unfortunately, it seems that the dynamically generated content is not well rendered, so I 'll give a static version of the test page.
Comment 1 Frédéric Wang (:fredw) 2011-12-06 13:25:50 PST
Created attachment 579435 [details]
Test stretchy and large operators
Comment 2 Frédéric Wang (:fredw) 2011-12-12 11:35:04 PST
Comment on attachment 579433 [details] [diff] [review]
Patch

I ask a review now, since fixing the issue with dynamically generated content seems out of the scope of this bug.
Comment 3 Karl Tomlinson (:karlt) 2011-12-14 18:29:04 PST
Comment on attachment 579433 [details] [diff] [review]
Patch

Looks good thanks.

Some things to consider as possible future improvements:

updateOperatorDictionary.pl would be easier to follow if the array index
constants were names, or, perhaps simpler, the data could be collected into
hash tables with the keys being 'description', 'lspace', etc.

I wonder whether it would be worthwhile considering operators that are
stretchy (have a direction) but are not stretchy by default.  e.g. &Sum.
Comment 4 Phil Ringnalda (:philor, back in August) 2011-12-24 17:17:28 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/9dfb1c2c5586
Comment 5 Phil Ringnalda (:philor, back in August) 2011-12-24 22:17:57 PST
https://hg.mozilla.org/mozilla-central/rev/9dfb1c2c5586

Note You need to log in before you can comment on or make changes to this bug.