Last Comment Bug 708109 - Eliminate THEBES_INLINE_DECL_THREADSAFE_REFCOUNTING
: Eliminate THEBES_INLINE_DECL_THREADSAFE_REFCOUNTING
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: mozilla11
Assigned To: Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
:
Mentors:
Depends on:
Blocks: 664918
  Show dependency treegraph
 
Reported: 2011-12-06 15:11 PST by Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
Modified: 2011-12-15 10:34 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (5.44 KB, patch)
2011-12-06 15:12 PST, Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
joe: review+
Details | Diff | Review

Description Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-12-06 15:11:43 PST
NS_INLINE_DECL_THREADSAFE_REFCOUNTING has been added, so we should eliminate THEBES_INLINE_DECL_THREADSAFE_REFCOUNTING.
Comment 1 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-12-06 15:12:37 PST
Created attachment 579478 [details] [diff] [review]
fix
Comment 2 Joe Drew (not getting mail) 2011-12-07 14:13:37 PST
Comment on attachment 579478 [details] [diff] [review]
fix

Review of attachment 579478 [details] [diff] [review]:
-----------------------------------------------------------------

These AddRef and Release are NS_METHOD_, which is pretty weird in thebes and layers. I don't know if it's a huge issue in practice, but I think we should be aware of this. I'll r- for now; please reflag for review if you think it's ok.
Comment 3 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-12-07 14:18:17 PST
Comment on attachment 579478 [details] [diff] [review]
fix

Review of attachment 579478 [details] [diff] [review]:
-----------------------------------------------------------------

I don't see that it matters.
Comment 4 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-12-07 16:00:47 PST
Comment on attachment 579478 [details] [diff] [review]
fix

Review of attachment 579478 [details] [diff] [review]:
-----------------------------------------------------------------

I don't see that it matters.
Comment 5 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-12-07 16:01:27 PST
It might matter if this added significantly to the dependency of layers on XPCOM, but that dependency is already pretty large.
Comment 6 Joe Drew (not getting mail) 2011-12-12 10:59:05 PST
Comment on attachment 579478 [details] [diff] [review]
fix

Review of attachment 579478 [details] [diff] [review]:
-----------------------------------------------------------------

I only mentioned it because it also changes the calling convention of AddRef and Release, but it's not a big deal, you're right.
Comment 7 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-12-15 02:30:07 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/4be841d52b5b
Comment 8 Matt Brubeck (:mbrubeck) 2011-12-15 10:34:16 PST
https://hg.mozilla.org/mozilla-central/rev/4be841d52b5b

Note You need to log in before you can comment on or make changes to this bug.