Last Comment Bug 708124 - Unnecessary glFlush calls in Layers code
: Unnecessary glFlush calls in Layers code
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla11
Assigned To: Jeff Gilbert [:jgilbert]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-06 16:13 PST by Jeff Gilbert [:jgilbert]
Modified: 2011-12-17 09:29 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove useless glFlush calls from Layers code (2.94 KB, patch)
2011-12-06 16:14 PST, Jeff Gilbert [:jgilbert]
jacob.benoit.1: review+
Details | Diff | Review

Description Jeff Gilbert [:jgilbert] 2011-12-06 16:13:26 PST
A couple Layers paths use glFlush before read-back with glReadPixels. This is not necessary, since glReadPixels must stall and synchronize the pipeline anyways.
Comment 1 Jeff Gilbert [:jgilbert] 2011-12-06 16:14:47 PST
Created attachment 579510 [details] [diff] [review]
Remove useless glFlush calls from Layers code
Comment 2 Benoit Girard (:BenWa) 2011-12-16 10:31:58 PST
Lets get this landed!
Comment 4 Matt Brubeck (:mbrubeck) 2011-12-17 09:29:13 PST
https://hg.mozilla.org/mozilla-central/rev/a5c58e9199a3

Note You need to log in before you can comment on or make changes to this bug.