docs.google.com - Space character eats existing text when IME is enabled with ひらがな/全角カタカナ mode and insert mode. (the behavior is like override mode)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

({inputmethod})

Trunk
x86
Windows 7
inputmethod
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/fafaf614791f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111206 Firefox/11.0a1 ID:20111206031117

Spece key eat existing text when IME is enabled with ひらがな/全角カタカナ mode and insert mode. (The behavior is like the override mode).

This happens with ATOK2006 and Microsoft Office IME2010.

* And Chinese IME also happens the problem. 
  See forum ( http://forums.mozillazine.org/viewtopic.php?f=23&t=2383769 )

* This problem happens on Firefox3.6.24 - Nightly11.0a1.
  so I think this is not a regression.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox with clean profile
2. Open URL ( https://docs.google.com/ )
3. Create Document
4. Type "abcdefghijklmn" without IME.
5. Switch IME on, ひらがな mode and insert mode
6. Move caret before "g"
7. Press Space bar to input a white space.

Actual Results:
 A white space is input. and it overwrite "g"

Expected Results:
 A white space is input. and it should not do overwrite "g"
(Reporter)

Updated

7 years ago
Summary: Spece character eat existing text when IME is enabled with ひらがな/全角カタカナ mode and insert mode. (the behavior like override mode) → Spece character eat existing text when IME is enabled with ひらがな/全角カタカナ mode and insert mode. (the behavior is like override mode)
(Reporter)

Updated

7 years ago
Summary: Spece character eat existing text when IME is enabled with ひらがな/全角カタカナ mode and insert mode. (the behavior is like override mode) → docs.google.com - Space character eats existing text when IME is enabled with ひらがな/全角カタカナ mode and insert mode. (the behavior is like override mode)

Comment 1

7 years ago
https://www.youtube.com/watch?v=kLQJWcUBJvk
Video illustrating the bug, if you do not have any affected IMEs in the computer.
A user from moztw.org mentions that s/he sees the bug in Ubuntu too, yet s/he does not state which IME is causing this.

Comment 2

7 years ago
A user reported that IE9 is having the same issue. Perhaps it is a Google Docs' issue rather than Firefox's.
Component: General → Widget: Win32
Product: Firefox → Core
QA Contact: general → win32

Comment 3

7 years ago
I cannot reproduce it anymore in Firefox 9.0.1 and Nightly 2012-01-08 build, as well as in IE9. Perhaps this has been fixed on the Google side.
(Reporter)

Comment 4

7 years ago
Confimed.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.