Last Comment Bug 708267 - Spellchecker misspelling error ("non sequitur", not "non sequiter")
: Spellchecker misspelling error ("non sequitur", not "non sequiter")
Status: RESOLVED FIXED
[good first bug][mentor=ehsan]
:
Product: Core
Classification: Components
Component: Spelling checker (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: mozilla22
Assigned To: chandankumar
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-07 09:05 PST by stacydan
Modified: 2013-03-07 00:59 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
It is a patch for the bug 708267. (52.77 KB, text/plain)
2013-03-02 03:29 PST, chandankumar
no flags Details
I have updated the patch for the bug 708267, (53.06 KB, text/plain)
2013-03-04 20:33 PST, chandankumar
no flags Details
It is a patch for the bug 708267. (277 bytes, text/plain)
2013-03-04 22:13 PST, chandankumar
no flags Details
It is a patch for the bug 708267. (33.44 KB, patch)
2013-03-05 06:37 PST, chandankumar
ehsan: review+
Details | Diff | Splinter Review

Description stacydan 2011-12-07 09:05:38 PST
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0.1) Gecko/20100101 Firefox/8.0.1
Build ID: 20111120135848

Steps to reproduce:

I occasionally encounter misspellings in the Thunderbird spellchecker


Actual results:

Non sequitur is returned as (non) requiter in hunderbird.  Curiously the spellchecker internal to this bug report recognizes  neither "sequiter" nor "sequitur" !  


Expected results:

(A non sequitur can denote an abrupt, illogical, unexpected or absurd turn of plot or dialogue not normally associated with or appropriate to that preceding it. A non sequitur joke has no explanation, but it reflects the idiosyncrasies, mental frames and alternative world of the particular comic persona.)  See most dictionaries. Also
http://en.wikipedia.org/wiki/Non_sequitur_(literary_device)

"I don't give a damn for a man that can only spell a word one way." -- Mark Twain 

I have a spelling checker 
It came with my PC 
It plainly marks for my revue 
Mistakes I cannot sea 
I've run this poem threw it 
I'm sure your please to no, 
It's letter perfect in it's weigh 
My checker tolled me sew 
-- anonymous
Comment 1 Hashem Masoud 2011-12-07 23:22:01 PST
(In reply to stacydan from comment #0)
Maybe because this is considered by the spell checker as 2 words, not one. You probably (I'm not sure) will get the same in the spell checker of MS Office Word.
Comment 2 Alex Moquin 2012-07-31 01:11:36 PDT
It turns out that MS Word will indeed spell check correctly for non sequitur (my version anyway). . .
However, looking at the source and README in extensions/spellcheck/locales/en-US/hunspell/ leads me to believe that this is something to be dealt with upstream, and https://sourceforge.net/tracker/?atid=1014602&group_id=10079&func=browse
seemed like the place to do it.
Even if it doesn't get added, I think it would probably be a good idea to sync the file hunspell-en_US-20081205.dic with the more recent file in the README and remake the en-US.dic to reflect the numerous other additions to the file
Comment 3 :Ehsan Akhgari 2012-08-10 12:32:09 PDT
(In reply to comment #2)
> It turns out that MS Word will indeed spell check correctly for non sequitur
> (my version anyway). . .
> However, looking at the source and README in
> extensions/spellcheck/locales/en-US/hunspell/ leads me to believe that this is
> something to be dealt with upstream, and
> https://sourceforge.net/tracker/?atid=1014602&group_id=10079&func=browse
> seemed like the place to do it.
> Even if it doesn't get added, I think it would probably be a good idea to sync
> the file hunspell-en_US-20081205.dic with the more recent file in the README
> and remake the en-US.dic to reflect the numerous other additions to the file

Could you create a patch for that, please?
Comment 4 chandankumar 2012-11-02 23:56:44 PDT
(in reply to comment #3)

Will i work on this.
i am a newbie. i know c language.
i found this bug interesting.
will i work on this?
Comment 5 smaudet 2012-12-26 11:29:42 PST
Looks like someone was working on it and then disappeared? I'll take a look see at it too.
Comment 6 :Ehsan Akhgari 2013-01-17 11:14:38 PST
Please see <https://developer.mozilla.org/en-US/docs/Adding_a_new_word_to_the_en-US_dictionary> for instructions on how to add a word to the en-US dictionary.
Comment 7 Pratik Sarkar 2013-01-17 12:25:57 PST
(In reply to :Ehsan Akhgari from comment #6)
> Please see
> <https://developer.mozilla.org/en-US/docs/Adding_a_new_word_to_the_en-
> US_dictionary> for instructions on how to add a word to the en-US dictionary.

I followed the steps given in the above link and I basically added the words "sequitur" and "nonsequitur" in my dictionary files.But I am stuck up with the step 7.What should I do?
Comment 8 :Ehsan Akhgari 2013-01-17 13:30:33 PST
(In reply to comment #7)
> (In reply to :Ehsan Akhgari from comment #6)
> > Please see
> > <https://developer.mozilla.org/en-US/docs/Adding_a_new_word_to_the_en-
> > US_dictionary> for instructions on how to add a word to the en-US dictionary.
> 
> I followed the steps given in the above link and I basically added the words
> "sequitur" and "nonsequitur" in my dictionary files.But I am stuck up with the
> step 7.What should I do?

Pratik, chandankumar is also working on this.  Any chance you could pick up another mentored bug please?  Thanks!
Comment 9 Arpit Agarwal 2013-02-27 23:13:49 PST
Google translator lists the word as non sequiter. Is it really a bug?
Comment 10 chandankumar 2013-03-02 03:29:45 PST
Created attachment 720265 [details]
It is a patch for the bug 708267.

I am attaching the patch for the bug 708267.
I have added two words "sequitur" and "non sequitur" in the dictionary.
Comment 11 stacydan 2013-03-02 06:48:35 PST
Thanks to all for thoughts and patches.  Ah!  The wonders of spell-checkers.  They do inject a bit of unintended humor in our lives. There's even a webpage on the logic of the non sequitur ("it does not follow" http://en.wikipedia.org/wiki/Non_sequitur_(logic)and of course the famous comic strip http://www.gocomics.com/nonsequitur and cast of characters http://en.wikipedia.org/wiki/Non_Sequitur_(comic_strip)
Comment 12 :Ehsan Akhgari 2013-03-04 11:38:56 PST
Comment on attachment 720265 [details]
It is a patch for the bug 708267.

Thanks for your patch.  But I think you only need to dd "sequitur" (lower case) to the dictionary.  "non" is already in there.
Comment 13 chandankumar 2013-03-04 20:33:26 PST
Created attachment 721052 [details]
I have updated the patch for the bug 708267,

i have modified the word "sequitur" in small letter.
it is working.
Comment 14 :Ehsan Akhgari 2013-03-04 20:59:14 PST
Comment on attachment 721052 [details]
I have updated the patch for the bug 708267,

Review of attachment 721052 [details]:
-----------------------------------------------------------------

Looks like you have created this patch on top of your previous patch.  Can you please create a patch on top of a clean tree?  Thanks!
Comment 15 chandankumar 2013-03-04 22:13:32 PST
Created attachment 721065 [details]
It is a patch for the bug 708267.
Comment 16 chandankumar 2013-03-04 22:14:43 PST
(In reply to :Ehsan Akhgari from comment #14)
>Can you please create a patch on top of a clean tree?  Thanks!
yes! I have created that one.
Please review it.
Comment 17 :Ehsan Akhgari 2013-03-05 06:16:22 PST
Comment on attachment 721065 [details]
It is a patch for the bug 708267.

Hmm, this patch is empty...
Comment 18 chandankumar 2013-03-05 06:37:19 PST
Created attachment 721223 [details] [diff] [review]
It is a patch for the bug 708267.

i have fully checked the patch.
please merge it.
Comment 19 chandankumar 2013-03-05 06:40:22 PST
(In reply to :Ehsan Akhgari from comment #17)
> Comment on attachment 721065 [details]
> It is a patch for the bug 708267.
> 
> Hmm, this patch is empty...
Sorry for that. i have cleaned the tree.
i have created the patch again.
Comment 20 :Ehsan Akhgari 2013-03-05 06:43:47 PST
Comment on attachment 721223 [details] [diff] [review]
It is a patch for the bug 708267.

Review of attachment 721223 [details] [diff] [review]:
-----------------------------------------------------------------

Looks great, thanks!
Comment 22 Ryan VanderMeulen [:RyanVM] 2013-03-05 07:36:54 PST
https://hg.mozilla.org/mozilla-central/rev/68b019bea6d4

Thanks for the patch!

Note You need to log in before you can comment on or make changes to this bug.