Note: There are a few cases of duplicates in user autocompletion which are being worked on.

NullPointerException in VideoPlayer on launch

RESOLVED FIXED in Firefox 11

Status

Fennec Graveyard
General
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: gcp, Assigned: blassey)

Tracking

({crash})

Firefox 9
Firefox 11
ARM
Android
crash
Dependency tree / graph

Details

(Whiteboard: [mobile-crash][inbound])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Happens whenever I try to launch.

    E/AndroidRuntime(17631): FATAL EXCEPTION: main
    E/AndroidRuntime(17631): java.lang.RuntimeException: Unable to start activity ComponentInfo{org.mozilla.fennec_morbo/org.mozilla.gecko.VideoPlayer}: java.lang.NullPointerException
    E/AndroidRuntime(17631):        at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1651)
    E/AndroidRuntime(17631):        at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:1667)
    E/AndroidRuntime(17631):        at android.app.ActivityThread.access$1500(ActivityThread.java:117)
    E/AndroidRuntime(17631):        at android.app.ActivityThread$H.handleMessage(ActivityThread.java:935)
    E/AndroidRuntime(17631):        at android.os.Handler.dispatchMessage(Handler.java:99)
    E/AndroidRuntime(17631):        at android.os.Looper.loop(Looper.java:130)
    E/AndroidRuntime(17631):        at android.app.ActivityThread.main(ActivityThread.java:3691)
    E/AndroidRuntime(17631):        at java.lang.reflect.Method.invokeNative(Native Method)
    E/AndroidRuntime(17631):        at java.lang.reflect.Method.invoke(Method.java:507)
    E/AndroidRuntime(17631):        at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:907)
    E/AndroidRuntime(17631):        at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:665)
    E/AndroidRuntime(17631):        at dalvik.system.NativeStart.main(Native Method)
    E/AndroidRuntime(17631): Caused by: java.lang.NullPointerException
    E/AndroidRuntime(17631):        at org.mozilla.gecko.VideoPlayer.onCreate(VideoPlayer.java:64)
    E/AndroidRuntime(17631):        at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1047)
    E/AndroidRuntime(17631):        at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1615)
    E/AndroidRuntime(17631):        ... 11 more
    W/ActivityManager( 2715):   Force finishing activity org.mozilla.fennec_morbo/org.mozilla.gecko.VideoPlayer
    I/dumpstate(17640): begin
Created attachment 579725 [details] [diff] [review]
patch
(Reporter)

Comment 2

6 years ago
I confirm this fixes the issue for me.

Updated

6 years ago
Component: General → General
Product: Fennec Native → Fennec
Target Milestone: --- → Firefox 9
Version: unspecified → Firefox 9

Updated

6 years ago
tracking-firefox9: --- → +
(Reporter)

Comment 3

6 years ago
More info: this is a Samsung Galaxy S2 with the stock Samsung firmware. Fresh compile and install of Fennec.

Updated

6 years ago
Blocks: 705572
(Assignee)

Updated

6 years ago
Attachment #579725 - Flags: review?(doug.turner)

Updated

6 years ago
Attachment #579725 - Flags: review?(doug.turner) → review+

Comment 4

6 years ago
i can't reproduce this crash on samsung galaxy S2, Fx9 beta 5 build.  Running a clean profile, i can open firefox, visit a youtube page, and launch the youtube player and play videos.  no crash.

gcp, can you share more details on your repro steps so i can reproduce?
(Reporter)

Comment 5

6 years ago
Not sure why version was set to 9 here? This was a XUL build from (approximately):
https://hg.mozilla.org/mozilla-central/rev/658fad825c36

There are no steps to reproduce, the crash is immediately after launch.
(Reporter)

Updated

6 years ago
tracking-firefox9: + → ---
Target Milestone: Firefox 9 → ---
Version: Firefox 9 → Trunk
(Assignee)

Updated

6 years ago
Attachment #579725 - Flags: approval-mozilla-beta?
Attachment #579725 - Flags: approval-mozilla-aurora?
Keywords: crash, reproducible
Whiteboard: [mobile-crash]
pushed to inbound https://hg.mozilla.org/integration/mozilla-inbound/rev/2087537890f0
Whiteboard: [mobile-crash] → [mobile-crash][inbound]
Naoki, why did you mark this as reproducible? Have you been able to reproduce it?
I think I marked this bug reproducible by mistake.  I was looking at multiple crashing bugs during this time.
Keywords: reproducible

Comment 9

6 years ago
Is it clear that beta is affected at this point?
(In reply to Alex Keybl [:akeybl] from comment #9)
> Is it clear that beta is affected at this point?

Yes.

A second shortcut is created on installation Firefox Beta, which when invoked causes this NPE.
Which is bug 708574
https://hg.mozilla.org/mozilla-central/rev/2087537890f0
Assignee: nobody → blassey.bugs
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 11
status-firefox10: --- → affected
status-firefox11: --- → fixed
status-firefox8: --- → unaffected
status-firefox9: --- → affected
Version: Trunk → Firefox 9
Blocks: 708574
Comment on attachment 579725 [details] [diff] [review]
patch

[Triage Comment]
We've now had a reproduction in 708574. Please land on aurora and beta. We'll be re-spinning beta 5 mobile this morning for this bug. Please make sure to land on the beta 5 branch of beta, as well as default/tip. Thanks!
Attachment #579725 - Flags: approval-mozilla-beta?
Attachment #579725 - Flags: approval-mozilla-beta+
Attachment #579725 - Flags: approval-mozilla-aurora?
Attachment #579725 - Flags: approval-mozilla-aurora+
pushed https://hg.mozilla.org/releases/mozilla-beta/rev/938d0e6afa57, https://hg.mozilla.org/releases/mozilla-beta/rev/f5cdfc9cea2e and https://hg.mozilla.org/releases/mozilla-aurora/rev/6443c93f7c9c

Updated

6 years ago
status-firefox10: affected → fixed
status-firefox9: affected → fixed
You need to log in before you can comment on or make changes to this bug.