Closed Bug 70834 Opened 19 years ago Closed 19 years ago

nspr autoconf can't configure correctly on NetBSD

Categories

(NSPR :: NSPR, defect, P1, critical)

All
NetBSD
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: taya, Assigned: wtc)

References

Details

Attachments

(4 files)

Recently, NSPR switched to autoconf, but can't configure correctly on NetBSD.
Some defines missing.(e.g.MDCPUCFG_H, PR_MD_CSRCS)
Keywords: patch
Marking NEW so someone will look at the patch.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: review
Who is someone?
Please assign to appropriate person.
Version: 4.0 → 4.1
Status: NEW → ASSIGNED
Blocks: 83943
Assigned the bug to me.
Assignee: larryh → wtc
Status: ASSIGNED → NEW
Priority: -- → P1
Target Milestone: --- → 4.2
Please give the patch a try.

I noticed that you set NSPR_USER_THREADS=1.  Is this because the
pthread library on NetBSD is not good enough?
Status: NEW → ASSIGNED
I'll try the patch tonight.
NetBSD doesn't have native pthread support.
Only optional pthread packages exists, but threy doesn't work with nspr.

With wtc's proposed patch v2 , I could build mozilla(0.9.1 branch) on
NetBSD-current/i386.
No longer blocks: 83943
*** Bug 83943 has been marked as a duplicate of this bug. ***
Thanks for verifying that the edited version of Taya's patch works.
r=wtc.

I'm going to request approval to check in the patch.
Blocks: 83989
a= asa@mozilla.org for checkin to the trunk.
(on behalf of drivers)
I checked in the patch on the trunk and NSPRPUB_CLIENT_BRANCH
of NSPR.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
I could build & run mozilla on NetBSD-current/i386(ELF) & NetBSD-1.5.1/mac68(a.out)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.