Scrolling is choppy and significantly slower than in Chrome

RESOLVED DUPLICATE of bug 675866

Status

()

RESOLVED DUPLICATE of bug 675866
7 years ago
7 years ago

People

(Reporter: notforyourmail, Unassigned)

Tracking

(Blocks: 1 bug)

11 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0a1) Gecko/20111207 Firefox/11.0a1
Build ID: 20111207031110

Steps to reproduce:

1) Load a complex page, such as engadget or Facebook.
2) Using a trackpad (laptop or magic trackpad), scroll down on the page with a flick.



Actual results:

Scrolling in chrome is fast and smooth.  
Scrolling in Firefox is slow and choppy.  Sometimes, the page appears to jump a bit when scrolling.


Expected results:

Scrolling in Firefox should be fast and smooth.

Comment 1

7 years ago
What are your settings under "Advanced > General > Browsing > Use smooth scrolling / Use hardware acceleration"?
(Reporter)

Comment 2

7 years ago
Hardware acceleration is enabled.

Note: this is an 8 core Mac Pro (mid 2009 model) with an ATI HD4870 and 12 GB RAM.
Blocks: 100951
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
This is almost certainly true, but there's not a lot to go on here. :/

Michael, do you know how to use Shark or Instruments to profile?
(Reporter)

Comment 4

7 years ago
Alas, I don't.
(Reporter)

Comment 5

7 years ago
But don't you have this happen as well?  It happens on all of my machines - even my fastest ones.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 675866
You need to log in before you can comment on or make changes to this bug.