Last Comment Bug 708407 - The menuitem label is unclickable if toolbarbutton type="menu" with CSS -moz-transform: scaleX(-1)
: The menuitem label is unclickable if toolbarbutton type="menu" with CSS -moz-...
Status: RESOLVED FIXED
fixed by bug 664707
:
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 664707 700975
Blocks: 435293
  Show dependency treegraph
 
Reported: 2011-12-07 13:51 PST by Alice0775 White
Modified: 2012-03-06 09:18 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase xul (1.24 KB, application/vnd.mozilla.xul+xml)
2011-12-07 13:51 PST, Alice0775 White
no flags Details

Description Alice0775 White 2011-12-07 13:51:47 PST
Created attachment 579829 [details]
testcase xul

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/fafaf614791f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111206 Firefox/11.0a1 ID:20111206031117


If toolbarbutton type="menu" with CSS -moz-transform: scaleX(-1) 
 The menuitem label is unclickable.
 Only the menuitem icon are clickable.

This causes Bug 700975.

toolbarbutton.button1,
toolbarbutton.button1 .toolbarbutton-text {
  -moz-transform: scaleX(-1);
}

<toolbarbutton class="button1" label="1Ooo" type="menu" orient="vertical">
  <menupopup>
    <menuitem label="label111111" class="menuitem-iconic"/>
    <menuitem label="label222222" class="menuitem-iconic"/>
    <menuitem label="label333333" class="menuitem-iconic"/>
  </menupopup>
</toolbarbutton>

Reproducible: Always
1. Open testcase

Actual Results:
 The menuitem label is unclickable.
 Only the menuitem icon is clickable.

Expected Results:
  The menuitem label should be clickable.
Comment 1 ItielMaN 2012-03-06 03:44:24 PST
Any progress?
Comment 2 Alice0775 White 2012-03-06 04:09:49 PST
I cannot reproduce anymore
http://hg.mozilla.org/mozilla-central/rev/433cfbd2a0da
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120305 Firefox/13.0a1 ID:20120305031045
Fixed by Bug 664707

Note You need to log in before you can comment on or make changes to this bug.