Last Comment Bug 708430 - New js MSVC2010 warnings: jsscope.h(511) C4309 & C4369
: New js MSVC2010 warnings: jsscope.h(511) C4309 & C4369
Status: RESOLVED FIXED
[build_warning]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla11
Assigned To: general
:
Mentors:
Depends on:
Blocks: buildwarning
  Show dependency treegraph
 
Reported: 2011-12-07 15:06 PST by Ed Morley [:emorley]
Modified: 2012-02-01 13:59 PST (History)
1 user (show)
emorley: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Ed Morley [:emorley] 2011-12-07 15:06:39 PST
A few hundred of these after the recent objshrink JM merge:
{
js/src/jsscope.h(511) : warning C4309: 'initializing' : truncation of constant value
js/src/jsscope.h(511) : warning C4369: 'FIXED_SLOTS_MASK' :  enumerator value '-134217728' cannot be represented as 'unsigned int', value is '4160749568'
}
Comment 1 Ed Morley [:emorley] 2011-12-07 15:13:09 PST
Line was last touched by https://hg.mozilla.org/mozilla-central/rev/ba69a907d9a4
Comment 2 Ed Morley [:emorley] 2011-12-08 12:40:33 PST
Fixed by:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a150aea6c244

(Pre-emptive marking resolved fixed, since that cset is marked no bug, so this won't end up being closed on merge otherwise).

Note You need to log in before you can comment on or make changes to this bug.