No Next button in the software keyboard when entering data into http://www.sweepstakes.com/

RESOLVED INVALID

Status

()

Firefox for Android
Keyboards and IME
P4
normal
RESOLVED INVALID
7 years ago
9 months ago

People

(Reporter: dougt, Unassigned, Mentored)

Tracking

(Depends on: 1 bug)

unspecified
ARM
Android
Points:
---

Firefox Tracking Flags

(fennec+)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
1) go to http://www.sweepstakes.com/
2) click on "Enter Now"
3) click on "First Name"

Notice no next button on the keyboard.
Priority: -- → P4
Doesn't this also have dependencies on the software keyboard that's being in use?
tracking-fennec: --- → ?
tracking-fennec: ? → +
my guess is the issue is that the input isn't the immediate parent of the input box. The fix in that case would be to walk up the dom looking to see if an ancestor is a form tag.
Created attachment 597241 [details]
Reduced test case made by Brad
Assignee: alex.mozilla → cpeterson
Note that Chrome Beta and the ICS stock browser show GO buttons, not NEXT buttons.

This behavior isn't technically a bug because you're supposed to be able to submit the form from any field. On the desktop, pressing ENTER in any form field will submit ("Go") the form. However, it is a poor user experience on mobile.
Component: General → IME
I suspect this bug will be fixed by bug 720475.
Depends on: 720475
OS: Mac OS X → Android
Hardware: x86 → ARM
Duplicate of this bug: 784546
Assignee: cpeterson → nobody
Whiteboard: [mentor=jchen]
(Assignee)

Updated

4 years ago
Mentor: nchen
Whiteboard: [mentor=jchen]
this  http://www.sweepstakes.com/ is for sale already.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID

Comment 8

9 months ago
See bug 1398374 for a website with the same issue.
You need to log in before you can comment on or make changes to this bug.