Last Comment Bug 708569 - IonMonkey: fix clang warnings
: IonMonkey: fix clang warnings
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Jan de Mooij [:jandem]
:
:
Mentors:
Depends on:
Blocks: IonMonkey
  Show dependency treegraph
 
Reported: 2011-12-08 02:59 PST by Jan de Mooij [:jandem]
Modified: 2011-12-10 05:19 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (7.34 KB, patch)
2011-12-08 03:12 PST, Jan de Mooij [:jandem]
nicolas.b.pierron: review+
Details | Diff | Splinter Review

Description Jan de Mooij [:jandem] 2011-12-08 02:59:38 PST

    
Comment 1 Jan de Mooij [:jandem] 2011-12-08 03:12:17 PST
Created attachment 579997 [details] [diff] [review]
Patch

Fixes all warnings with Clang 3.0 in js/src/ion on x86 and x64. It looks like the type of some variables was changed from int32 to uint32 at some point. This also fixes some cases where we used %d instead of %u in IonSpew although Clang did not complain about it.
Comment 2 Nicolas B. Pierron [:nbp] 2011-12-09 11:38:55 PST
Comment on attachment 579997 [details] [diff] [review]
Patch

Review of attachment 579997 [details] [diff] [review]:
-----------------------------------------------------------------

Good.
Comment 3 Jan de Mooij [:jandem] 2011-12-10 05:19:22 PST
Pushed:

http://hg.mozilla.org/projects/ionmonkey/rev/c110288b93ec

Note You need to log in before you can comment on or make changes to this bug.