Last Comment Bug 708594 - Slow right-click response with add-on Firegesture
: Slow right-click response with add-on Firegesture
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: 8 Branch
: x86 Windows 7
: -- normal (vote)
: Firefox 13
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
https://github.com/TTimo/doom3.gpl/bl...
Depends on: 705877
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-08 05:01 PST by dindog
Modified: 2012-03-13 12:03 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description dindog 2011-12-08 05:01:07 PST
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:8.0.1) Gecko/20100101 Firefox/8.0.1
Build ID: 20111207031110

Steps to reproduce:

1. install add-on Firegesture (FG for short below), it's a AMO feature add-on with roughly 550k users. link:
https://addons.mozilla.org/en-US/firefox/addon/firegestures/?src=search
2. By default, FG will draw right-click mouse down trail, and some site will make right-click response really slow, e.g. GitHub source page, similar to Bug 704911.
3. If turning off "Drawing Trail" option, this issue disappears.
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2012-01-12 19:53:28 PST
This addon modifies the DOM on right click, looks like.  There are all sorts of ways that could go wrong performance-wise depending on the DOM and the modifications they make to it...  Probably worth retesting once bug 705877 is fixed.
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2012-03-12 21:01:16 PDT
Bug 705877 landed on inbound.  Could you maybe retest with nightlies a few days from now?
Comment 3 dindog 2012-03-13 09:50:53 PDT
(In reply to Boris Zbarsky (:bz) from comment #2)
> Bug 705877 landed on inbound.  Could you maybe retest with nightlies a few
> days from now?
test with today(20120313) nightly, issue fixed
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2012-03-13 12:03:15 PDT
Great, thank you for testing that!

Note You need to log in before you can comment on or make changes to this bug.