Last Comment Bug 708745 - Fennec gets into a bad state trying to handle opening new tabs via target attributes in anchor tags
: Fennec gets into a bad state trying to handle opening new tabs via target att...
Status: VERIFIED FIXED
[MTD][readability]
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P3 normal (vote)
: Firefox 11
Assigned To: Kartikaya Gupta (email:kats@mozilla.com)
:
: Sebastian Kaspari (:sebastian)
Mentors:
: 709666 (view as bug list)
Depends on:
Blocks: font-inflation
  Show dependency treegraph
 
Reported: 2011-12-08 11:18 PST by Bret Reckard
Modified: 2012-09-12 07:32 PDT (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
verified
11+


Attachments
Screenshot of broken UI (104.08 KB, image/jpeg)
2011-12-08 11:18 PST, Bret Reckard
no flags Details
Improve support for opening new tabs/windows (3.31 KB, patch)
2011-12-16 08:58 PST, Kartikaya Gupta (email:kats@mozilla.com)
mark.finkle: review+
Details | Diff | Splinter Review

Description Bret Reckard 2011-12-08 11:18:52 PST
Created attachment 580113 [details]
Screenshot of broken UI

So, could be a problem with Bugzilla's website, but you can't easily login to Bugzilla via the mobile browser to file a bug.

Steps: use the mobile browser
- Find a crash report on about:crashes
- Click on one of the reports
- Click "report this crash" button
- click/poke the "email address" text box to login

Result:
- UI compacts and keyboard disappears
- Can't login

Expected:
- Normal Login process for a website



Ugly System Dump:

  Application Basics

        Name
        Fennec

        Version
        11.0a1

        User Agent
        Mozilla/5.0 (Android; Linux armv7l; rv:11.0a1) Gecko/20111207 Firefox/11.0a1 Fennec/11.0a1

        Profile Directory

          Open Containing Folder

        Enabled Plugins

          aboutlugins

        Build Configuration

          about:buildconfig

        Crash Reports

          about:crashes

        Memory Use

          about:memory

  Extensions

        Name

        Version

        Enabled

        ID

        Adblock Plus
        1.3.10
        false
        {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

        Phony
        2.0.2
        false
        phony@mbrubeck.limpet.net

  Modified Preferences

      Name

      Value

        browser.startup.homepage_override.mstone

        extensions.lastAppVersion
        11.0a1

        network.cookie.prefsMigrated
        true

        places.database.lastMaintenance
        1323356877

        places.history.expiration.transient_current_max_pages
        21940

        places.history.expiration.transient_optimal_database_size
        35103866

        privacy.donottrackheader.enabled
        true

  Graphics

        Adapter Description
        Android, Model: 'GT-I9100', Product: 'GT-I9100', Manufacturer: 'samsung', Hardware: 'smdkc210'

        Vendor ID
        0127

        Device ID
        a234

        WebGL Renderer
        ARM -- Mali-400 MP -- OpenGL ES 2.0

        GPU Accelerated Windows
        0. Blocked for your graphics card because of unresolved driver issues.

        AzureBackend
        skia
Comment 1 Alex Keybl [:akeybl] 2011-12-08 12:13:43 PST
This looks like a text formatting issue on crash-stats. Including
Comment 2 Alex Keybl [:akeybl] 2011-12-08 12:16:07 PST
Including dbaron*
Comment 3 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-12-12 09:37:23 PST
There seems to be multiple issues listed in this bug, may we separate them out?
To confirm on the issues : 

- drop downs cannot be read - dup of bug 706609
- cannot log in : is this because the VKB does not appear when you click in the text field?
- font are too large - dup of bug 705446
Comment 4 Bret Reckard 2011-12-12 12:36:50 PST
I don't believe this is the correct separation.  Also, what is VKB?  I'll come down to show you Naoki and you can decide :).
Comment 5 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-12-12 23:30:02 PST
Ok, I'll see you tomorrow.  Sorry I didn't reply earlier.  VKB = Virtual Keyboard aka Soft Keyboard aka the keyboard that pops open on the display when you click on a text field.
Comment 7 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-12-13 16:21:00 PST
*** Bug 709666 has been marked as a duplicate of this bug. ***
Comment 8 Kartikaya Gupta (email:kats@mozilla.com) 2011-12-14 12:44:33 PST
This is caused by the link having target="_NEW". I was able to set up a simplified test page at http://people.mozilla.org/~kgupta/bug/708745.html - clicking the link forces a new tab open, which Fennec Native completely mishandles. It renders the new page in the same tab, but has messed-up internal state, so as soon as you try to do anything with the page (like tapping on a text field) it goes back to painting the old page.
Comment 9 Kartikaya Gupta (email:kats@mozilla.com) 2011-12-16 08:58:23 PST
Created attachment 582290 [details] [diff] [review]
Improve support for opening new tabs/windows

Based on my testing this seems to work ok. I'm a bit unsure about what the rules are for opening chrome pages and stuff using window.open. e.g. window.open("about:blank") works for me in desktop FFx but gets blocked in fennec (before it gets to browser.js, I think). I can investigate that further if this code needs to handle privilege issues like that.
Comment 10 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-16 09:18:02 PST
Comment on attachment 582290 [details] [diff] [review]
Improve support for opening new tabs/windows

I have this same patch (almost identical) in my queue. Looks good to me.
Comment 11 Kartikaya Gupta (email:kats@mozilla.com) 2011-12-16 14:03:47 PST
Landed on m-i:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b407ff123b6f
Comment 12 Matt Brubeck (:mbrubeck) 2011-12-17 09:27:28 PST
https://hg.mozilla.org/mozilla-central/rev/b407ff123b6f
Comment 13 Doug Turner (:dougt) 2011-12-17 22:12:09 PST
backed out
Comment 14 Kartikaya Gupta (email:kats@mozilla.com) 2011-12-19 09:56:32 PST
Re-landed on m-i after testing to verify it doesn't introduce a regression.

https://hg.mozilla.org/integration/mozilla-inbound/rev/7744b924b806
Comment 15 Ed Morley [:emorley] 2011-12-20 06:09:12 PST
https://hg.mozilla.org/mozilla-central/rev/7744b924b806
Comment 16 Brad Lassey [:blassey] (use needinfo?) 2012-01-09 10:43:44 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/7744b924b806
Comment 17 Cristian Nicolae (:xti) 2012-09-12 07:32:07 PDT
I cannot reproduce this issue on the latest Nightly build. Closing bug as verified fixed on:

Firefox 18.0a1 (2012-09-12)
Device: Galaxy Note
OS: Android 4.0.4

Note You need to log in before you can comment on or make changes to this bug.