Closed Bug 708753 Opened 8 years ago Closed 7 years ago

Firefox Button menu items has broken keyboard support, and is missing accelerators (underlined letters)

Categories

(Firefox :: Menus, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: danweiss, Unassigned)

References

Details

On the normal menus, things work beautifully.  Arrow keys work fine to navigate within the menus, and move from menu to menu.  There are proper keyboard accelerators (underlined letters), which can activate the menu items by pressing that key on the keyboard.

But on the Firefox Button's menu, things are completely broken:
* After opening the menu by clicking the Firefox button, there is no response from any keyboard keys, except Alt, Escape, Tab, or Windows Key to close the menu.
* After hovering over a menu items, it displays the usual dark blue to indicate the item is selected.  Once a menu item is selected, you can use the arrow keys to move to some of the other menu items, and press Enter to activate that items.  You can not move to any split items, nor move between the left and right half of the menu.
* After hovering over a split menu item (such as the New Tab menu), you can press Right to open the submenu, and navigate within the submenu, but you can not navigate to any other menu items with the keyboard.
* No keyboard letters activate any commands, not even pressing the first letter of the command name.
* There are no keyboard accelerators (underlined letters) on any of the menu items.  Not even on any items in the submenus.

On submenus of the Firefox Button Menu, keyboard letter keys work to activate the menu item that begins with that letter, but there are still no displayed accelerators (underlined letters).

Yes, I have confirmed the same behavior on a clean profile.

Also, when using the "Personal Menu" add-on, custom menus added to the Firefox Button menu have proper accelerators.  Why can't the real menu have them too?
Please, add bug "FirefoxButton" as a blocking to this one. This will raise the chances of that bug to be noticed by mozdevs. Otherwise it may stay ignored for years.
Thank you for the suggestion, but how do I do that?
This is due to the presence of boxes within the menupopup.  The keyboard (arrow keys, home, end, etc) cannot navigate across box boundaries inside a menupopup.

The accelerator issue is addressed elsewhere by several bugs.
The Firefox button is going to be removed in bug 863753.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
:dao , will the new 'menu' button feature keyboard access?
I don't think it currently has keyboard access and I wouldn't count on it getting keyboard access.
(In reply to Dão Gottwald [:dao] from comment #6)
> I don't think it currently has keyboard access and I wouldn't count on it
> getting keyboard access.

In this case it is possible that an analog of this bug will eventually be opened for that button - provided that the proactive people who create bugs like this are not scared away from recreating a similar bug and if they, hopefully, still stick to Firefox!

Is it possible to transfer this bug for the menu button? Keyboard people will still seek keyboard access, even if the implementation and the UX changes, I think.
I would suggest filing a new bug, as the new menu is quite a bit different from the one this bug was filed for.
You need to log in before you can comment on or make changes to this bug.