Last Comment Bug 708777 - IonMonkey: Assertion failure: unexpected type, at Lowering.cpp:538
: IonMonkey: Assertion failure: unexpected type, at Lowering.cpp:538
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: David Anderson [:dvander]
:
Mentors:
Depends on:
Blocks: 677337
  Show dependency treegraph
 
Reported: 2011-12-08 12:06 PST by Jan de Mooij [:jandem]
Modified: 2012-02-03 18:12 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (2.77 KB, patch)
2012-02-03 16:54 PST, David Anderson [:dvander]
bhackett1024: review+
Details | Diff | Splinter Review

Description Jan de Mooij [:jandem] 2011-12-08 12:06:46 PST
jit-tests/tests/jaeger/recompile/undef.js asserts. Here's a reduced testcase without callgname:
--
function local() {
    var x;
    x++;
    return x;
}
local();
--
Asserts when lowering MToInt32(undefined).
Comment 1 David Anderson [:dvander] 2012-02-03 16:54:19 PST
Created attachment 594364 [details] [diff] [review]
fix
Comment 2 Brian Hackett (:bhackett) 2012-02-03 17:04:37 PST
Comment on attachment 594364 [details] [diff] [review]
fix

Review of attachment 594364 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/shell/js.cpp
@@ +5461,5 @@
>          || !op.addStringOption('\0', "ion-gvn", "[mode]",
>                                 "Specify Ion global value numbering:\n"
>                                 "  off: disable GVN\n"
> +                               "  pessimistic: (default) use pessimistic GVN\n"
> +                               "  optimistic: use optimistic GVN")

Intended for this patch?
Comment 3 David Anderson [:dvander] 2012-02-03 18:12:21 PST
http://hg.mozilla.org/projects/ionmonkey/rev/55fe4b0baa59

Note You need to log in before you can comment on or make changes to this bug.