Closed Bug 708887 Opened 13 years ago Closed 1 year ago

Cannot print iFrame content under Mac OS X 10.7

Categories

(Core :: Printing: Output, defect)

8 Branch
x86
macOS
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mozillabugzilla, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Attached file - jsFiddle demo.pdf
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_1) AppleWebKit/534.48.3 (KHTML, like Gecko) Version/5.1 Safari/534.48.3

Steps to reproduce:

Using Mac OS X 10.7.1, and Firefox 8.0.1 or Nightly 11.0a1 (2011-12-08): opened a page which contained an iFrame whose window.onload contained a function telling that iFrame to print. Example: http://jsfiddle.net/WZh3V/



Actual results:

Print dialog box appears, however clicking "print" results in no action; clicking "PDF > Save As PDF…" produces a zero-byte PDF file.


Expected results:

Print dialog box should appear and clicking "Print" should result in document being sent to the print spooler. Click "PDF > Save as PDF…" should save the PDF, not produce a zero-byte file. Correct behavior is seen on Mac OS X 10.5 and Mac OS X 10.6. Correct behavior is seen under Mac OS X 10.7 using Safari or Chrome.
Also, using Firefox 8.0.1, clicking the "Print" link in the demo results in a modal dialog box "Printer Not Available". Same thing happens when right clicking and choosing "This Frame > Print frame". *This* behavior is not reproducible in Nightly, only in 8.0.1.

Attaching screenshot of this issue.
This is Firefox 8.0.1 -- This *works* in Nightly
(In reply to Joshua Gitlin from comment #3)
> Created attachment 580227 [details]
> "Right Click > This Frame > Print Frame" Results
> 
> This is Firefox 8.0.1 -- This *works* in Nightly

You you mind searching for a range that might have fixed this? It would be good for tracking, but otherwise 8 is 2 versions ago and won't get any patches.
I am able to reproduce the bug in version in 9.0.1 if that's what you're asking Paul...
(In reply to Joshua Gitlin from comment #5)
> I am able to reproduce the bug in version in 9.0.1 if that's what you're
> asking Paul...

How about 10?
Severity: normal → S3

Unable to reproduce.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Component: General → Printing: Output
Product: Firefox → Core
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: