Last Comment Bug 709083 - DoneCreatingElement for button called in the wrong place
: DoneCreatingElement for button called in the wrong place
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: HTML: Parser (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-09 07:48 PST by Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01)
Modified: 2012-03-20 03:45 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Move DoneCreatingElement (5.24 KB, patch)
2012-01-04 00:27 PST, Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01)
bzbarsky: review+
Details | Diff | Splinter Review
Exclude the test from Fennec (1.21 KB, patch)
2012-03-19 04:11 PDT, Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01)
bzbarsky: review+
Details | Diff | Splinter Review

Description Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2011-12-09 07:48:29 PST
DoneCreatingElement should be called after adding all attributes. It's now called after adding all children.
Comment 1 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2012-01-04 00:27:17 PST
Created attachment 585673 [details] [diff] [review]
Move DoneCreatingElement
Comment 2 Boris Zbarsky [:bz] 2012-01-31 21:13:19 PST
Comment on attachment 585673 [details] [diff] [review]
Move DoneCreatingElement

r=me.  Sorry for the lag.....
Comment 3 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2012-02-03 05:33:55 PST
Thanks for the r+. Landed.

https://hg.mozilla.org/integration/mozilla-inbound/rev/3335984ce688
Comment 4 Jonathan Kew (:jfkthame) 2012-02-03 07:11:40 PST
And backed out, because it turned Android mochitest-8 orange:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8f2ca4c209e4
Comment 5 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2012-02-03 08:02:26 PST
Android-specific XBL seems to be interfering with the Mochitest added here:
1263 INFO TEST-START | /tests/parser/htmlparser/tests/mochitest/test_bug709083.html
1264 ERROR TEST-UNEXPECTED-FAIL | /tests/parser/htmlparser/tests/mochitest/test_bug709083.html | an unexpected uncaught JS exception reported through window.onerror - this.clickToPlay is null at chrome://global/content/bindings/videocontrols.xml:1230
1265 INFO TEST-PASS | /tests/parser/htmlparser/tests/mochitest/test_bug709083.html | Should be muted already.
1266 INFO TEST-END | /tests/parser/htmlparser/tests/mochitest/test_bug709083.html | finished in 5151ms
Comment 6 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2012-03-15 06:27:15 PDT
So the mochitest added here failed in Fennec XUL. Would it be OK to make the test exit early in Fennec XUL considering that Fennec XUL is not in focus anymore?
Comment 7 Boris Zbarsky [:bz] 2012-03-15 12:28:37 PDT
Yeah, I think so.
Comment 8 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2012-03-19 04:11:21 PDT
Created attachment 607111 [details] [diff] [review]
Exclude the test from Fennec

I couldn't find a way to check for Fennec XUL specifically in a makefile.
Comment 9 Boris Zbarsky [:bz] 2012-03-19 07:32:11 PDT
Comment on attachment 607111 [details] [diff] [review]
Exclude the test from Fennec

r=me if you add a comment with a bug number about this (and of course file said bug).
Comment 10 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2012-03-19 07:50:56 PDT
Thanks. Filed bug 737020.

Relanded
https://hg.mozilla.org/integration/mozilla-inbound/rev/cfbacfc02abd
https://hg.mozilla.org/integration/mozilla-inbound/rev/32e7b965ddb5

Note You need to log in before you can comment on or make changes to this bug.