Last Comment Bug 709205 - use services::GetObserverService instead of do_GetService
: use services::GetObserverService instead of do_GetService
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla11
Assigned To: Nathan Froyd [:froydnj]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-09 11:03 PST by Nathan Froyd [:froydnj]
Modified: 2011-12-17 09:34 PST (History)
4 users (show)
bzbarsky: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
use GetObserverService in docshell, dom (4.65 KB, patch)
2011-12-09 11:37 PST, Nathan Froyd [:froydnj]
bzbarsky: review+
Details | Diff | Review
use GetObserverService in places (1.39 KB, patch)
2011-12-09 11:38 PST, Nathan Froyd [:froydnj]
mak77: review+
Details | Diff | Review
use GetObserverService in xpcom (1.83 KB, patch)
2011-12-09 11:38 PST, Nathan Froyd [:froydnj]
dougt: review+
Details | Diff | Review
use GetObserverService in places (2.00 KB, patch)
2011-12-16 09:31 PST, Nathan Froyd [:froydnj]
nfroyd: review+
Details | Diff | Review

Description Nathan Froyd [:froydnj] 2011-12-09 11:03:25 PST
Several do_GetService(NS_OBSERVERSERVICE_CONTRACTID) calls have snuck in over time; the incoming patches replace them with their equivalent, mozilla::services::GetObserverService.  There are still a couple two-argument do_GetService(NS_OBSERVERSERVICE_CONTRACTID, &rv) calls lying about; I chose not to handle those in this patchset.
Comment 1 Nathan Froyd [:froydnj] 2011-12-09 11:37:33 PST
Created attachment 580484 [details] [diff] [review]
use GetObserverService in docshell, dom

Simple patch for docshell and dom.
Comment 2 Nathan Froyd [:froydnj] 2011-12-09 11:38:10 PST
Created attachment 580485 [details] [diff] [review]
use GetObserverService in places

Simple patch for places.
Comment 3 Nathan Froyd [:froydnj] 2011-12-09 11:38:42 PST
Created attachment 580486 [details] [diff] [review]
use GetObserverService in xpcom

Simple patch for xpcom.
Comment 4 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-12-09 19:17:44 PST
Comment on attachment 580484 [details] [diff] [review]
use GetObserverService in docshell, dom

r=me
Comment 5 Marco Bonardo [::mak] 2011-12-10 05:19:09 PST
Comment on attachment 580485 [details] [diff] [review]
use GetObserverService in places

Review of attachment 580485 [details] [diff] [review]:
-----------------------------------------------------------------

In both places you may use just services:: since those files already have using namespace mozilla;
Comment 6 Nathan Froyd [:froydnj] 2011-12-16 09:31:57 PST
Created attachment 582296 [details] [diff] [review]
use GetObserverService in places

Adjusted to account for mak's comments and drive-by-fixes to other mozilla::services:: instances in the touched files.  Mak approved the drive-by-fixes on IRC.  Carrying over r+.

Note You need to log in before you can comment on or make changes to this bug.