nsXPConnect::Traverse should use JS_PrintTraceThingInfo to generate debug strings

RESOLVED DUPLICATE of bug 735449

Status

()

Core
XPConnect
RESOLVED DUPLICATE of bug 735449
6 years ago
6 years ago

People

(Reporter: mccr8, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
The code in Traverse that generates the string description of a JS thing is very fragile and JS-implementation specific.  JS_PrintTraceThingInfo does almost the same thing anyways, so we should fix up JS_PrintTraceThingInfo so it produces comparable information, make it available in non-debug builds, then call it from Traverse instead of that big chunk of code.
(Reporter)

Updated

6 years ago
Blocks: 723783
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 735449
You need to log in before you can comment on or make changes to this bug.