The default bug view has changed. See this FAQ.

Form history repository layer

VERIFIED FIXED in Firefox 13

Status

Android Background Services
Android Sync
P1
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: ally, Assigned: nalexander)

Tracking

(Blocks: 1 bug)

unspecified
mozilla14
All
Android
Dependency tree / graph

Firefox Tracking Flags

(firefox13 fixed, firefox14 fixed, blocking-fennec1.0 beta+)

Details

(Whiteboard: [sync])

Attachments

(1 attachment)

Comment hidden (empty)
Will depend on a Fennec content provider.
OS: Mac OS X → Android
Hardware: x86 → All
Summary: repo layer for form history → Form history repository layer
Priority: -- → P3
(Reporter)

Updated

5 years ago
Depends on: 725881
(Reporter)

Updated

5 years ago
Assignee: nobody → nalexander
Priority: P3 → P1
Keywords: fennecnative-betablocker
blocking-fennec1.0: --- → beta+
Status: NEW → ASSIGNED
Depends on: 730557
Depends on: 733422
Whiteboard: [sync]
Part 1:

https://hg.mozilla.org/integration/mozilla-inbound/rev/5a555fb12c22
Whiteboard: [sync] → [sync][Leave open after merge]
Created attachment 608782 [details]
Stub for Aurora approval.

Routine Sync approval for Aurora.
Attachment #608782 - Flags: approval-mozilla-aurora?
Nick's test procedure:

For reference, this is my test procedure:

 * Test Fennec -> Desktop
   - Add new form item in Fennec
   - Sync device, Sync desktop, check appears on Desktop
   - Delete form item in Fennec
   - Sync device, Sync desktop, check item no longer appears on Desktop, and is not revived in Fennec
     * THIS DOES NOT WORK
     * Instead, check that server has correct deleted record (using Dump the cleartext of each record in a collection
       to the console. from https://wiki.mozilla.org/Services/Sync/Snippets)
   - Sync device again, check that record is not revived in Fennec
 * Test Desktop -> Fennec
   - Add new form item in Desktop
   - Sync desktop, Sync device, check appears in Fennec
   - Delete form item in Desktop
   - Sync desktop, Sync device, check item no longer appears in Fennec, and is not revived in Desktop
 * Test reconcile same
   - Add new form item in Desktop
   - Add same form item in Fennec with same form value
   - Sync desktop, then sync device
   - Check single form item with Desktop GUID appears in Fennec and Desktop, and has Desktop's form value in both
 * Test reconcile different
   - Add new form item in Desktop
   - Add same form item in Fennec with different form value
   - Sync desktop, then sync device
   - Check two form items appear in Fennec and Desktop
(In reply to Richard Newman [:rnewman] from comment #2)
> Part 1:
> 
> https://hg.mozilla.org/integration/mozilla-inbound/rev/5a555fb12c22

https://hg.mozilla.org/mozilla-central/rev/5a555fb12c22

Comment 6

5 years ago
Comment on attachment 608782 [details]
Stub for Aurora approval.

[Triage Comment]
If these changes are mobile-only and are not dependent upon the Maple uplift to Aurora, a=akeybl for Aurora 13.
Attachment #608782 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Reporter)

Comment 7

5 years ago
work for this is on github, and is progressing there.
https://hg.mozilla.org/integration/mozilla-inbound/rev/9638f8e27e00
Whiteboard: [sync][Leave open after merge] → [sync]
Target Milestone: --- → mozilla14
Note that this is preffed off (well, hard-coded disabled) by design: this'll have a big performance impact until batching lands.

When I find the bug number for that, I'll set the appropriate dependencies and file a follow-up to pref on.
Blocks: 742104
https://hg.mozilla.org/mozilla-central/rev/9638f8e27e00
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
https://hg.mozilla.org/releases/mozilla-aurora/rev/bf8c6122a969
status-firefox13: --- → fixed
status-firefox14: --- → fixed

Updated

5 years ago
Status: RESOLVED → VERIFIED
Component: Android Sync → Android Sync
Product: Mozilla Services → Android Background Services
You need to log in before you can comment on or make changes to this bug.