Last Comment Bug 709485 - Regression: Tablet UI browser does not resize correctly after toggling sidebar
: Regression: Tablet UI browser does not resize correctly after toggling sidebar
Status: VERIFIED FIXED
: regression
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Firefox 10
: All All
: -- normal (vote)
: Firefox 11
Assigned To: Matt Brubeck (:mbrubeck)
:
:
Mentors:
Depends on:
Blocks: 692357
  Show dependency treegraph
 
Reported: 2011-12-10 09:26 PST by Matt Brubeck (:mbrubeck)
Modified: 2013-12-10 10:00 PST (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch (880 bytes, patch)
2011-12-10 09:26 PST, Matt Brubeck (:mbrubeck)
mark.finkle: review+
asa: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Matt Brubeck (:mbrubeck) 2011-12-10 09:26:26 PST
Created attachment 580655 [details] [diff] [review]
patch

Steps to reproduce:
1. Open XUL Fennec in landscape mode on a Honeycomb tablet.
2. If the tab sidebar is not visible, drag or tap to show it.
3. Drag the sidebar to hide it.
4. Tap the tabs button in the toolbar to show the sidebar.

Actual results: The tab sidebar appears, but the browser and actionbar do not resize so they are pushed off the edge of the screen.

This is a regression from bug 692357.  It happens because TabletSidebar.grab() tells the browser sizing code to ignore the the sidebar, but ungrab() does not always tell it to stop ignoring.  This one-line change to TabletSidebar.hide() ensures that we stop ignoring the sidebar no matter which code path we take in ungrab().
Comment 1 Matt Brubeck (:mbrubeck) 2011-12-12 12:26:30 PST
https://hg.mozilla.org/mozilla-central/rev/ee96343f8e13
Comment 2 Matt Brubeck (:mbrubeck) 2011-12-12 12:28:01 PST
Comment on attachment 580655 [details] [diff] [review]
patch

Requesting approval for Aurora 10.  This is a one-line, mobile-only fix for a user-visible regression in update 10.  The fix is safe and has very low regression potential.
Comment 3 Matt Brubeck (:mbrubeck) 2011-12-13 15:07:44 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/209f0e816c81
Comment 4 Cristian Nicolae (:xti) 2011-12-29 07:11:40 PST
Verified fixed on:
Mozilla/5.0 (Android;Linux armv7l;rv:10.0)Gecko/20111228
Firefox/10.0 Fennec/10.0
Devices: Asus EEE Transformer
OS: Android 3.2.1

Note You need to log in before you can comment on or make changes to this bug.