Last Comment Bug 709567 - B2G SMS: DOM to RIL plumbing in ril_worker.js
: B2G SMS: DOM to RIL plumbing in ril_worker.js
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: ARM Gonk (Firefox OS)
: -- normal (vote)
: mozilla12
Assigned To: Philipp von Weitershausen [:philikon]
:
Mentors:
Depends on:
Blocks: b2g-sms
  Show dependency treegraph
 
Reported: 2011-12-11 04:02 PST by Philipp von Weitershausen [:philikon]
Modified: 2011-12-24 22:10 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Part 1 (v1): Plumbing for incoming SMS (4.89 KB, patch)
2011-12-17 19:39 PST, Philipp von Weitershausen [:philikon]
kyle: review+
Details | Diff | Splinter Review
Part 2 (v1): Plumbing for outgoing SMS (7.48 KB, patch)
2011-12-22 15:30 PST, Philipp von Weitershausen [:philikon]
kyle: review+
Details | Diff | Splinter Review

Description Philipp von Weitershausen [:philikon] 2011-12-11 04:02:44 PST
Pretty straight forward stuff, just need to do the extra PDU parsing/formatting step (bug 709566)
Comment 1 Philipp von Weitershausen [:philikon] 2011-12-17 19:39:34 PST
Created attachment 582624 [details] [diff] [review]
Part 1 (v1): Plumbing for incoming SMS

This is the plumbing for incoming SMS. Pipes messages through the PDU parser and sends events to the main thread.
Comment 2 Kyle Machulis [:kmachulis] [:qdot] 2011-12-19 13:12:32 PST
Comment on attachment 582624 [details] [diff] [review]
Part 1 (v1): Plumbing for incoming SMS

Review of attachment 582624 [details] [diff] [review]:
-----------------------------------------------------------------

Fairly straight forward changes, looks good.
Comment 3 Philipp von Weitershausen [:philikon] 2011-12-22 15:30:55 PST
Created attachment 583954 [details] [diff] [review]
Part 2 (v1): Plumbing for outgoing SMS

For outgoing SMS, the whole encoding issue is a bit tricky. Since the mainthread is going to have to calculate how many text messages a certain payload will take (which will involve choosing an appropriate encoding, etc.), we might as well pass that information (appropriate encoding, byte length in encoded form) down from the mainthread. We don't do this yet, for now it's hard coded. But this should explain the somewhat awkward structure.

If we find a better way some time donw the road, we can always refactor, too.
Comment 4 Kyle Machulis [:kmachulis] [:qdot] 2011-12-22 15:52:39 PST
Comment on attachment 583954 [details] [diff] [review]
Part 2 (v1): Plumbing for outgoing SMS

Review of attachment 583954 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. r=me.

Note You need to log in before you can comment on or make changes to this bug.