Last Comment Bug 709579 - Closing multiple tabs warning doesn't work correctly when the "Show my windows and tabs from last time" option is selected
: Closing multiple tabs warning doesn't work correctly when the "Show my window...
Status: RESOLVED DUPLICATE of bug 419009
:
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: 8 Branch
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-11 06:54 PST by alley81al
Modified: 2012-12-13 08:54 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description alley81al 2011-12-11 06:54:41 PST
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:8.0.1) Gecko/20100101 Firefox/8.0.1
Build ID: 20111120135848

Steps to reproduce:

if i have a ff window open with multiple tabs, and i have the 'warn me b4 i close all' clicked in options, it doesn't work. it still closes.
if i have 2 windows open, both with multi tabs, the primary window still closes, but the 2nd one gives me the warning.
i had the 'never save history' clicked and i was losing all my tabs info, so i clicked it off, and now the warning shows up if i try to close multi tabs on the primary window.

i was trying to submit this here
http://input.mozilla.com/en-US/feedback#sad
but i'm only allowed 140 characters.
Comment 1 Ioana (away) 2012-01-09 06:08:01 PST
Verified on:
Mozilla/5.0 (Windows NT 5.1; rv:12.0a1) Gecko/20120108 Firefox/12.0a1

This issue only reproduces when both the "Warn me when closing multiple tabs" and "Show my windows and tabs from last time" options are selected.

STR:
 1. Launch Firefox with a clean profile.
 2. Make sure both the "Warn me when closing multiple tabs" and "Show my windows and tabs from last time" options are selected in Tools->Options.
 3. Load some web pages in different tabs.
 4. Open a second Fx window and load at least two web pages in different tabs in this second window.
 5. Close the second Fx window. Click on the "Close tabs" button on the warning.
 6. Close the first window.
 7. Reopen Fx, then close it again.

The warning about closing multiple tabs is displayed at step 5, but not at step 6 and 7. If the user keeps reopening Fx and opening multiple tabs, the warning is  sometimes displayed.

I checked and the "Warn me when closing multiple tabs" stayed checked the whole time I kept opening Fx with multiple tabs and closing it.
Comment 2 alex_mayorga 2012-08-23 08:08:52 PDT
Duplicate of either bug 419009 or bug 702478 perhaps?
Comment 3 Mardeg 2012-08-24 05:59:57 PDT
Current workaround is to set browser.showQuitWarning to true in about:config
Comment 4 Fanolian 2012-12-13 06:07:34 PST
(In reply to Mardeg from comment #3)
> Current workaround is to set browser.showQuitWarning to true in about:config

This workaround does not work on FF17.0.1 and Nightly (20121212 build).
I can still reproduce the bug in Win7 64bit on FF17.0.1 and Nightly 32bit.
Comment 5 mizucol 2012-12-13 07:25:52 PST
An issue is related to this one. (firefox 17, 18, nightly)

After installing firefox and using panorama the first time,
the "When Firefox Starts" item will be forced to be "Show my windows and tabs from last time". (Is this a right reaction?)
Thus, after using panorama, consequently, "Warn me when closing multiple tabs" doesn't work.
Comment 6 VanillaMozilla 2012-12-13 08:54:29 PST
This has nothing to do with the "Show my windows and tabs from last time" option or the panorama function, whatever that is.  Version 17.0.1 fails even if set to open home page.

Marking as a duplicate.  Please feel free to undupe it if there's a good reason.  Dataloss bug reported in 2008, developers distracted by shiny object.  Feel free to devise creative bug-reporting strategy to get this fixed.

*** This bug has been marked as a duplicate of bug 419009 ***

Note You need to log in before you can comment on or make changes to this bug.