Last Comment Bug 709653 - Fix GC heap memory reporters
: Fix GC heap memory reporters
Status: RESOLVED FIXED
[MemShrink:P2]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla11
Assigned To: Nicholas Nethercote [:njn] (on vacation until July 11)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-11 21:15 PST by Nicholas Nethercote [:njn] (on vacation until July 11)
Modified: 2011-12-19 05:42 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (19.20 KB, patch)
2011-12-11 21:15 PST, Nicholas Nethercote [:njn] (on vacation until July 11)
bhackett1024: review+
Details | Diff | Review

Description Nicholas Nethercote [:njn] (on vacation until July 11) 2011-12-11 21:15:47 PST
Created attachment 580826 [details] [diff] [review]
patch

I found that the sum of all the GC heap memory reporters was about 5% 
greater than the total size of the GC heap.  Turns out there there two culprits: 

- The computation of gcHeapChunkDirtyUnused didn't account for 
  gcHeapShapesBase.

- "type-inference/object-main" was incorrectly marked as having 
  JS_GC_HEAP_KIND.

So "explicit", "gc-heap-chunk-dirty-unused", and "heap-unclassified" were all inflated slightly.

I added an assertion to make sure that this mismatch will be detected if it
occurs again in the future.  (This assertion would also have caught the 
incorrect kind markings in bug 704391.)

I also renamed countDecommittedArenas() because it was confusing the hell 
out of me.
Comment 1 Nicholas Nethercote [:njn] (on vacation until July 11) 2011-12-18 15:41:24 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/2b94d12f3e2d
Comment 2 Marco Bonardo [::mak] 2011-12-19 05:42:40 PST
https://hg.mozilla.org/mozilla-central/rev/2b94d12f3e2d

Note You need to log in before you can comment on or make changes to this bug.