mozilla will not launch, until ProfileManager has run, but cannot launch profilemanager!

VERIFIED DUPLICATE of bug 53952

Status

Core Graveyard
Profile: Migration
--
critical
VERIFIED DUPLICATE of bug 53952
17 years ago
2 years ago

People

(Reporter: Ken Snider, Assigned: racham)

Tracking

({hang})

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)
BuildID:    20010305

I have been unable to get *any* current Mozilla build (including NS 6) to start 
on my system. Upon launching the browser, The "working" (pointer+hourglass) 
icon is shown, and an entry is created in the tasklist, but nothing appears, 
not even the splash page.
WinTop shows a single thread or mozilla running, having utilized NO CPU time.

System is Windows Millennium, up to date WindowsUpdate-wise. AMD Athlon w/up to 
date 4-in-1 drivers, NVidia Graphics card. On a fresh bootup with all startup 
applications disabled, no change, the browser will still not load.

Reproducible: Always
Steps to Reproduce:
1. Attempt to launch the browser. Using flags like -console, etc. have no effect


Actual Results:  An entry is created in the tasklist, and memory is allocated, 
but no ohter effect.

Expected Results:  See the cute Mozilla splash screen!

I cannot create a talkback crash because it doesn't "crash". Talkback or not, 
no effect. Worst part is, I want to use Mozilla to help with QA. :)
(Reporter)

Comment 1

17 years ago
Ok, more info.

I was able to launch the browser in Windows "Safe Mode", with the
-profilemanager switch. After this, the browser opened without issue.

So now the question is, what is preventing even the profile manager from
launching? :)
Summary: mozilla will not launch, no reaction to starting app → mozilla will not launch, until ProfileManager has run, but cannot launch profilemanager!
(Reporter)

Comment 2

17 years ago
Yet more info. :)

Downloaded the latest nightly.

Had the same problem starting it.

Using, wintop, I grabbed a list of items running locally on my system:

Kernel32.dll
msgsrv32.exe
mmtask.tsk
mprexe.exe
mstask.exe
ssdpsrv.exe
stimon.exe
explorer.exe
taskmon.exe
systray.exe
stmgr.exe
wmiexe.exe

.. and Mozilla wouldn't run.

The scary part is, I rebooted. All those same subsystems were active, no more,
no less. But you know what? Mozilla launched! AND, once it launched once, it
will launch again without issue!

*boggle*

Comment 3

17 years ago
i'll acuse stimon.exe

let's also acuse profile migration.

also consider depends.exe from http://dependencywalker.com and filemon 
from http://sysinternals.com
Assignee: asa → racham
Severity: blocker → critical
Component: Browser-General → Profile Migration
QA Contact: doronr → gbush
(Reporter)

Comment 4

17 years ago
Well, I can now just about guarantee it isn't profile migration.

After leaving my system overnight, I find that it exhibits the same symptoms. 
Rebooting makes it quite available.

So now the question is, what's hanging Mozilla?

A better question, how can I find out? I've never used the two tools suggested 
before, but will do so happily. What should I look for, or is there a "dump" I 
can provide back to you folks?

Comment 5

17 years ago
usage for depends: run depends, use it to 'open' mozilla, tell it to start 
profiling, select all options, tell it to run mozilla.
usage for filemon: run filemon, give it a list of processes. i think 
mozilla*;stimon* will do

unfortunately, i suspect the problem is related to DDE, and although i have 
some DDE test apps, i don't have any DDE debugging apps.
Keywords: hang

Comment 6

17 years ago
This is another instance of the problem described in bug 53952.  One of the apps
on your system is blocking DDE and there's not much we can do (save stop using
DDE, which is a royal PITA).

I had this problem on a Win98 system and I had to disable some Windows doodad (I
don't remember exactly what it was, but try closing things in your system tray
one at a time till you find the culprit).

Bug 53952 still needs attention.  I'm going to escalate that one a bit...

*** This bug has been marked as a duplicate of 53952 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 7

17 years ago
verify duplicate
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.