Setting TB colours to white text on black results in black on black when printing

NEW
Unassigned

Status

7 years ago
3 years ago

People

(Reporter: bjl, Unassigned)

Tracking

x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0.1) Gecko/20100101 Firefox/8.0.1
Build ID: 20111120135848

Steps to reproduce:

Within the TB Display options I set text colour to white and background colour to black.


Actual results:

When I print messages they come out as black on black ie. a solid page of black below the mail headers which print OK as black on white.


Expected results:

The whole page should print as black on white ie. the background colour should be white not black.

Comment 1

7 years ago
(In reply to BJ from comment #0)
Confirmed here:
User Agent: Mozilla/5.0 (X11; Linux i686; rv:8.0) Gecko/20111105 Thunderbird/8.0
Build ID: 20111105021619

If you keep it black text on white background though, it prints normally. I tried it to print to pdf file (not to physical file).
Status: UNCONFIRMED → NEW
Component: Preferences → Printing
Ever confirmed: true
Product: Thunderbird → MailNews Core
QA Contact: preferences → printing
I wonder if something similar to this would happen in Firefox.
(Reporter)

Comment 3

7 years ago
I just tested in Firefox and the problem doesn't occur.

I went to the FF Content setttings and changed the Text coour to white and the Background colour to black. Then printed a page. The text colour came out black, the backgroung colour came out white, and the link colours came out as set.

So when printing in FF the text and background colour settings as set by the user seem to be ignored.

Presumably this is what TB needs to do.
(Reporter)

Comment 4

7 years ago
PS. I do have mail views set to compose and display in plain test.
Removing myslef on all the bugs I'm cced on. Please NI me if you need something on MailNews Core bugs from me.
You need to log in before you can comment on or make changes to this bug.