Last Comment Bug 709776 - Move tri-licensed Android library parts under mozutils
: Move tri-licensed Android library parts under mozutils
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: mozilla12
Assigned To: Mike Hommey [:glandium]
:
: Gregory Szorc [:gps]
Mentors:
Depends on: 701371
Blocks: 683127
  Show dependency treegraph
 
Reported: 2011-12-12 07:20 PST by Mike Hommey [:glandium]
Modified: 2012-01-26 23:54 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Move tri-licensed Android library parts under mozutils/ (4.58 KB, patch)
2011-12-12 07:22 PST, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review
Move tri-licensed Android library parts under mozutils/ (6.07 KB, patch)
2011-12-12 11:27 PST, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review
Move tri-licensed Android library parts under mozutils/ (4.58 KB, patch)
2011-12-12 11:47 PST, Mike Hommey [:glandium]
blassey.bugs: review+
Details | Diff | Splinter Review
Move tri-licensed Android library parts under mozglue/. (4.57 KB, patch)
2011-12-22 00:56 PST, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review
Move tri-licensed Android library parts under mozglue/ - for aurora (4.63 KB, patch)
2012-01-25 08:51 PST, Mike Hommey [:glandium]
mh+mozilla: review+
blassey.bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2011-12-12 07:20:42 PST
There is no real reason to keep our Gecko android c++ code under other-licenses/android when the code is tri-licensed.
Comment 1 Mike Hommey [:glandium] 2011-12-12 07:22:57 PST
Created attachment 580903 [details] [diff] [review]
Move tri-licensed Android library parts under mozutils/
Comment 2 Mike Hommey [:glandium] 2011-12-12 11:27:22 PST
Created attachment 580982 [details] [diff] [review]
Move tri-licensed Android library parts under mozutils/

Refreshed
Comment 3 Mike Hommey [:glandium] 2011-12-12 11:47:06 PST
Created attachment 580991 [details] [diff] [review]
Move tri-licensed Android library parts under mozutils/

Edited the wrong patch on the wrong bug. Restoring the previous one.
Comment 4 Mike Hommey [:glandium] 2011-12-22 00:56:19 PST
Created attachment 583736 [details] [diff] [review]
Move tri-licensed Android library parts under mozglue/.

Refreshed patch against bug 701371, which instead of just moving mozutils, also now renames it.
Comment 6 Mike Hommey [:glandium] 2011-12-28 03:28:30 PST
Backed out because of random and unexplainable android bustages.
https://hg.mozilla.org/integration/mozilla-inbound/rev/db6e5b2bf92d
Comment 7 Mike Hommey [:glandium] 2012-01-10 00:21:21 PST
The Android bustages were due to the missing ANDROID_ARM_LINKER definition in mozglue/android/Makefile.in (it's the only DEFINE from other-licenses/android/Makefile.in that is used in APKOpen.cpp). The result is that we were missing the cache flushes from bug 690856 and were hitting it again.
https://hg.mozilla.org/integration/mozilla-inbound/rev/c899dde43144
Comment 8 Ed Morley [:emorley] 2012-01-10 11:49:38 PST
https://hg.mozilla.org/mozilla-central/rev/c899dde43144
Comment 9 Mike Hommey [:glandium] 2012-01-25 08:51:38 PST
Created attachment 591485 [details] [diff] [review]
Move tri-licensed Android library parts under mozglue/ - for aurora

[Approval Request Comment]
This is a dependency for bug 683127 and bug 713228. It only moves code around.
Comment 10 Mike Hommey [:glandium] 2012-01-26 23:54:25 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/3352a89d2dde

Note You need to log in before you can comment on or make changes to this bug.