Closed Bug 709832 Opened 8 years ago Closed 8 years ago

crash [@ mozalloc_abort] typing with vkb in url on the EEEpad Transformer

Categories

(Firefox for Android :: General, defect, blocker)

All
Android
defect
Not set
blocker

Tracking

()

RESOLVED FIXED

People

(Reporter: martijn.martijn, Assigned: blassey)

Details

(Keywords: crash, Whiteboard: [native-crash])

Crash Data

Attachments

(4 files, 1 obsolete file)

This bug was filed from the Socorro interface and is 
report bp-67e3a857-b76d-43ce-ad31-0692d2111212 .
============================================================= 
0 	libmozalloc.so 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:66
1 	libc.so 	pthread_mutex_unlock 	
2 	dalvik-heap (deleted) 	dalvik-heap @0x1d51ffe 	
3 	libcutils.so 	mspace_malloc 	
4 		@0x5ec10006 	
5 	libdvm.so 	dvmPlatformInvoke 	
6 	libdvm.so 	dvmCallJNIMethod_general 	
7 	libdvm.so 	dvmResolveNativeMethod 	
8 	libdvm.so 	dvmAsmSisterStart 	
9 	libdvm.so 	dvmMterpStd 	
10 	libdvm.so 	dvmInterpret 	
11 	libdvm.so 	dvmInvokeMethod 	
12 	libdvm.so 	dvmFreeDexOrJar 	
13 	libdvm.so 	dvmAsmSisterStart 	
14 	libdvm.so 	dvmMterpStd 	
15 	libdvm.so 	dvmInterpret 	
16 	libdvm.so 	dvmCallMethodV 	
17 	libdvm.so 	JNI_CreateJavaVM 	
18 	libandroid_runtime.so 	_ZN7android14AndroidRuntime6onExitEi 	
19 	libandroid_runtime.so 	_ZN7android14AndroidRuntime5startEPKcb 	
20 	app_process 	app_process@0xe27 	
21 	app_process 	app_process@0x2026 	
22 	libandroid_runtime.so 	_ZN7android47register_android_animation_PropertyValuesHolderEP7_JNIEnv 
etc..
It seems to happen almost all the time for me on the EEEpad transformer, making it almost impossible to type in urls in the url bar.
OS: Linux → Android
Product: Fennec → Fennec Native
Version: Trunk → unspecified
Whiteboard: [native-crash]
This is actually preventing me from using Native Fennec on the EEEpad.
Severity: critical → blocker
Severity: blocker → critical
(In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #1)
> It seems to happen almost all the time for me on the EEEpad transformer,
> making it almost impossible to type in urls in the url bar.

Martijn, could you provide a bit more information please?
Is this the first Transformer, model TF101?
Do you use the standard ASUS English (US) Keyboard or some other IME?
What are exact steps, and when exactly the crash happens? During typing or after you press Go and the URL is being loaded?
Severity: critical → blocker
I've got it crashed once - after I pressed Go, and Fennec started loading the site. Here's what I see in the logcat:

12-14 17:04:34.094: ERROR/DatabaseUtils(15289): Writing exception to parcel
        android.database.sqlite.SQLiteConstraintException: error code 19: constraint failed
        at android.database.sqlite.SQLiteStatement.native_executeInsert(Native Method)
        at android.database.sqlite.SQLiteStatement.executeInsert(SQLiteStatement.java:112)
        at android.database.sqlite.SQLiteDatabase.insertWithOnConflict(SQLiteDatabase.java:1737)
        at android.database.sqlite.SQLiteDatabase.insertOrThrow(SQLiteDatabase.java:1636)
        at com.android.browser.provider.BrowserProvider2.insertInTransaction(BrowserProvider2.java:1200)
        at com.android.browser.provider.SQLiteContentProvider.insert(SQLiteContentProvider.java:115)
        at android.content.ContentProvider$Transport.insert(ContentProvider.java:203)
        at android.content.ContentProviderNative.onTransact(ContentProviderNative.java:153)
        at android.os.Binder.execTransact(Binder.java:339)
        at dalvik.system.NativeStart.run(Native Method)
12-14 17:04:34.094: WARN/dalvikvm(15278): threadid=18: thread exiting with uncaught exception (group=0x40202760)
12-14 17:04:34.104: ERROR/AndroidRuntime(15278): FATAL EXCEPTION: AsyncTask #4
        java.lang.RuntimeException: An error occured while executing doInBackground()
        at android.os.AsyncTask$3.done(AsyncTask.java:266)
        at java.util.concurrent.FutureTask$Sync.innerSetException(FutureTask.java:273)
        at java.util.concurrent.FutureTask.setException(FutureTask.java:124)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:307)
        at java.util.concurrent.FutureTask.run(FutureTask.java:137)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1081)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:574)
        at java.lang.Thread.run(Thread.java:1020)
        Caused by: android.database.sqlite.SQLiteConstraintException: error code 19: constraint failed
        at android.database.DatabaseUtils.readExceptionFromParcel(DatabaseUtils.java:172)
        at android.database.DatabaseUtils.readExceptionFromParcel(DatabaseUtils.java:136)
        at android.content.ContentProviderProxy.insert(ContentProviderNative.java:447)
        at android.content.ContentResolver.insert(ContentResolver.java:721)
        at org.mozilla.gecko.db.AndroidBrowserDB.updateFaviconForUrl(AndroidBrowserDB.java:278)
        at org.mozilla.gecko.db.BrowserDB.updateFaviconForUrl(BrowserDB.java:134)
        at org.mozilla.gecko.Favicons$LoadFaviconTask.saveFaviconToDb(Favicons.java:248)
        at org.mozilla.gecko.Favicons$LoadFaviconTask.downloadFavicon(Favicons.java:299)
        at org.mozilla.gecko.Favicons$LoadFaviconTask.doInBackground(Favicons.java:355)
        at org.mozilla.gecko.Favicons$LoadFaviconTask.doInBackground(Favicons.java:215)
        at android.os.AsyncTask$2.call(AsyncTask.java:252)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:305)
Severity: blocker → critical
Attached file logcat of crash
This is a logcat of a crash, happening while pressing five times 'm' on the vkb.
Yes, this is with the first Transformer, model TF101. Yes, this is with the standard ASUS English (US) Keyboard, at least, I didn't change it, afaik.
This is happening during typing in the url bar.
Attached image screenshot of vkb
Screenshot of the vkb that is being used.
This is preventing me from using the product on the Transformer, so upgrading severity to blocker.
Severity: critical → blocker
Attached file second logcat of crash (obsolete) —
Here is an additional logcat. It seems to be happening when I type something in that doesn't exist (like something like 'mmm') in the autocomplete list. Although I can trigger the crash also very easily in different ways.

And here a logcat only showing the errors. These are the errors by typing 3 times 'mmm' in the url bar:
12-15 17:56:25.716: E/GeckoApp(23218): top level exception
12-15 17:56:25.716: E/GeckoApp(23218): java.lang.IllegalArgumentException: bad base-64
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.util.Base64.decode(Base64.java:161)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.util.Base64.decode(Base64.java:136)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.util.Base64.decode(Base64.java:118)
12-15 17:56:25.716: E/GeckoApp(23218): 	at org.mozilla.gecko.AwesomeBarTabs$AwesomeBarCursorAdapter.getDrawableFromDataURI(AwesomeBarTabs.java:478)
12-15 17:56:25.716: E/GeckoApp(23218): 	at org.mozilla.gecko.AwesomeBarTabs$AwesomeBarCursorAdapter.bindSearchEngineView(AwesomeBarTabs.java:506)
12-15 17:56:25.716: E/GeckoApp(23218): 	at org.mozilla.gecko.AwesomeBarTabs$AwesomeBarCursorAdapter.getView(AwesomeBarTabs.java:471)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.widget.AbsListView.obtainView(AbsListView.java:1949)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.widget.ListView.measureHeightOfChildren(ListView.java:1228)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.widget.ListView.onMeasure(ListView.java:1139)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.view.View.measure(View.java:10835)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:4351)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.widget.FrameLayout.onMeasure(FrameLayout.java:267)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.view.View.measure(View.java:10835)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:4351)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.widget.LinearLayout.measureChildBeforeLayout(LinearLayout.java:1284)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.widget.LinearLayout.measureVertical(LinearLayout.java:613)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.widget.LinearLayout.onMeasure(LinearLayout.java:519)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.view.View.measure(View.java:10835)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:4351)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.widget.FrameLayout.onMeasure(FrameLayout.java:267)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.view.View.measure(View.java:10835)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:4351)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.widget.LinearLayout.measureChildBeforeLayout(LinearLayout.java:1284)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.widget.LinearLayout.measureVertical(LinearLayout.java:613)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.widget.LinearLayout.onMeasure(LinearLayout.java:519)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.view.View.measure(View.java:10835)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:4351)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.widget.FrameLayout.onMeasure(FrameLayout.java:267)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.view.View.measure(View.java:10835)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:4351)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.widget.LinearLayout.measureChildBeforeLayout(LinearLayout.java:1284)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.widget.LinearLayout.measureVertical(LinearLayout.java:613)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.widget.LinearLayout.onMeasure(LinearLayout.java:519)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.view.View.measure(View.java:10835)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:4351)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.widget.FrameLayout.onMeasure(FrameLayout.java:267)
12-15 17:56:25.716: E/GeckoApp(23218): 	at com.android.internal.policy.impl.PhoneWindow$DecorView.onMeasure(PhoneWindow.java:1889)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.view.View.measure(View.java:10835)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.view.ViewRoot.performTraversals(ViewRoot.java:944)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.view.ViewRoot.handleMessage(ViewRoot.java:2046)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.os.Handler.dispatchMessage(Handler.java:99)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.os.Looper.loop(Looper.java:132)
12-15 17:56:25.716: E/GeckoApp(23218): 	at org.mozilla.gecko.GeckoApp$28.run(GeckoApp.java:1403)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.os.Handler.handleCallback(Handler.java:587)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.os.Handler.dispatchMessage(Handler.java:92)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.os.Looper.loop(Looper.java:132)
12-15 17:56:25.716: E/GeckoApp(23218): 	at android.app.ActivityThread.main(ActivityThread.java:4123)
12-15 17:56:25.716: E/GeckoApp(23218): 	at java.lang.reflect.Method.invokeNative(Native Method)
12-15 17:56:25.716: E/GeckoApp(23218): 	at java.lang.reflect.Method.invoke(Method.java:491)
12-15 17:56:25.716: E/GeckoApp(23218): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:841)
12-15 17:56:25.716: E/GeckoApp(23218): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:599)
12-15 17:56:25.716: E/GeckoApp(23218): 	at dalvik.system.NativeStart.main(Native Method)
12-15 17:56:25.786: D/AlarmManager(135): Triggered Alarm 415415b8 ELAPSED_REALTIME_WAKEUP IntentSender{409bcf00: PendingIntentRecord{40e600c8 org.sipdroid.sipua broadcastIntent}}
12-15 17:56:25.796: D/AlarmManager(135): Added alarm Alarm{40b3d488 type 2 org.sipdroid.sipua} type:ELAPSED_REALTIME_WAKEUP when: After 0h:1m:0.0s
12-15 17:56:25.796: D/AlarmManager(135): Removed alarm Alarm{40b3d488 type 2 org.sipdroid.sipua} type:ELAPSED_REALTIME_WAKEUP
12-15 17:56:25.796: D/AlarmManager(135): Added alarm Alarm{40b1efe8 type 2 org.sipdroid.sipua} type:ELAPSED_REALTIME_WAKEUP when: After 0h:1m:0.0s
12-15 17:56:25.796: D/AlarmManager(135): Removed alarm Alarm{40db74e8 type 2 org.sipdroid.sipua} type:ELAPSED_REALTIME_WAKEUP
12-15 17:56:25.796: D/AlarmManager(135): Added alarm Alarm{40ae0110 type 2 org.sipdroid.sipua} type:ELAPSED_REALTIME_WAKEUP when: After 0h:9m:59.0s
12-15 17:56:26.046: D/Zygote(89): Process 23218 exited cleanly (1)
12-15 17:56:26.056: I/ActivityManager(135): Process org.mozilla.fennec (pid 23218) has died.
12-15 17:56:26.056: I/WindowManager(135): WIN DEATH: Window{41518c68 org.mozilla.fennec/org.mozilla.fennec.App paused=false}
12-15 17:56:26.056: W/WindowManager(135): Force-removing child win Window{41f74c60 SurfaceView paused=false} from container Window{41518c68 org.mozilla.fennec/org.mozilla.fennec.App paused=false}
12-15 17:56:26.056: W/WindowManager(135): Failed looking up window
12-15 17:56:26.056: W/WindowManager(135): java.lang.IllegalArgumentException: Requested window android.os.BinderProxy@40fdce90 does not exist
12-15 17:56:26.056: W/WindowManager(135): 	at com.android.server.wm.WindowManagerService.windowForClientLocked(WindowManagerService.java:6744)
12-15 17:56:26.056: W/WindowManager(135): 	at com.android.server.wm.WindowManagerService.windowForClientLocked(WindowManagerService.java:6735)
12-15 17:56:26.056: W/WindowManager(135): 	at com.android.server.wm.WindowState$DeathRecipient.binderDied(WindowState.java:1390)
12-15 17:56:26.056: W/WindowManager(135): 	at android.os.BinderProxy.sendDeathNotice(Binder.java:418)
12-15 17:56:26.056: W/WindowManager(135): 	at dalvik.system.NativeStart.run(Native Method)
12-15 17:56:26.056: I/WindowManager(135): WIN DEATH: null
12-15 17:56:26.056: I/WindowManager(135): WIN DEATH: Window{413eee70 org.mozilla.fennec/org.mozilla.gecko.AwesomeBar paused=false}
12-15 17:56:26.086: I/ActivityManager(135): Start proc org.mozilla.fennec for activity org.mozilla.fennec/.App: pid=23268 uid=10079 gids={3003, 1015, 1006}
12-15 17:56:26.136: D/dalvikvm(89): GC_EXPLICIT freed 12K, 6% free 6301K/6659K, paused 2ms+3ms
12-15 17:56:26.156: D/WindowManager(135): adjustConfigurationLw, config:{1.0 0mcc0mnc (no locale) sw800dp w1280dp h752dp xlrg land ?uimode ?night finger -keyb/v/h -nav/v} mLidOpen:-1 mHasDockFeature:true mHasHallSensorFeature:true config.hardKeyboardHidden:2
12-15 17:56:26.186: D/AndroidRuntime(23267): >>>>>> AndroidRuntime START com.android.internal.os.RuntimeInit <<<<<<
12-15 17:56:26.186: D/AndroidRuntime(23267): CheckJNI is OFF
12-15 17:56:26.216: D/dalvikvm(89): GC_EXPLICIT freed <1K, 6% free 6301K/6659K, paused 2ms+2ms
12-15 17:56:26.226: I/ActivityThread(23268): Pub org.mozilla.gecko.providers.browser: org.mozilla.gecko.db.BrowserProvider
12-15 17:56:26.236: D/GeckoBrowserProvider(23268): Creating BrowserProvider
12-15 17:56:26.256: D/dalvikvm(23268): Trying to load lib /data/data/org.mozilla.fennec/lib/libmozutils.so 0x40750ca8
12-15 17:56:26.256: D/dalvikvm(23268): Added shared lib /data/data/org.mozilla.fennec/lib/libmozutils.so 0x40750ca8
12-15 17:56:26.256: D/dalvikvm(23268): No JNI_OnLoad found in /data/data/org.mozilla.fennec/lib/libmozutils.so 0x40750ca8, skipping init
12-15 17:56:26.256: W/GeckoApp(23268): zerdatime 1323968186265 - onCreate
12-15 17:56:26.266: D/dalvikvm(89): GC_EXPLICIT freed <1K, 6% free 6301K/6659K, paused 2ms+2ms
12-15 17:56:26.306: D/dalvikvm(23268): GC_FOR_ALLOC freed 75K, 4% free 6473K/6727K, paused 28ms
12-15 17:56:26.306: I/dalvikvm-heap(23268): Grow heap (frag case) to 6.919MB for 513744-byte allocation
12-15 17:56:26.346: D/dalvikvm(23268): GC_FOR_ALLOC freed <1K, 4% free 6974K/7239K, paused 27ms
12-15 17:56:26.416: D/AndroidRuntime(23267): Calling main entry com.android.commands.am.Am
12-15 17:56:26.426: D/AndroidRuntime(23267): Shutting down VM
12-15 17:56:26.426: I/ActivityManager(135): Starting: Intent { act=org.mozilla.gecko.reportCrash flg=0x10000000 cmp=org.mozilla.fennec/.CrashReporter (has extras) } from pid 23267
12-15 17:56:26.436: D/dalvikvm(23267): GC_CONCURRENT freed 102K, 86% free 373K/2560K, paused 1ms+0ms
12-15 17:56:26.436: D/jdwp(23267): Got wake-up signal, bailing out of select
12-15 17:56:26.436: D/dalvikvm(23267): Debugger has detached; object registry had 1 entries
12-15 17:56:26.436: D/dalvikvm(23268): GC_CONCURRENT freed 4K, 3% free 7211K/7431K, paused 2ms+4ms
12-15 17:56:26.456: W/ResourceType(23268): Too many attribute references, stopped at: 0x01010099
12-15 17:56:26.476: D/GeckoFavicons(23268): Creating Favicons instance
12-15 17:56:26.476: D/GeckoFavicons(23268): Creating DatabaseHelper
12-15 17:56:26.496: W/GeckoApp(23268): zerdatime 1323968186502 - UI almost up
12-15 17:56:26.496: W/GeckoApp(23268): zerdatime 1323968186507 - onStart
12-15 17:56:26.496: I/GeckoApp(23268): start
12-15 17:56:26.506: I/GeckoApp(23268): resume
12-15 17:56:26.506: W/GeckoApp(23268): zerdatime 1323968186512 - onNewIntent
12-15 17:56:26.506: W/GeckoApp(23268): zerdatime 1323968186512 - launch
12-15 17:56:26.506: I/GeckoAppShell(23268): env0: null
12-15 17:56:26.516: I/GeckoApp(23268): pause
12-15 17:56:26.526: D/WindowManager(135): adjustConfigurationLw, config:{1.0 0mcc0mnc (no locale) sw800dp w1280dp h752dp xlrg land ?uimode ?night finger -keyb/v/h -nav/v} mLidOpen:-1 mHasDockFeature:true mHasHallSensorFeature:true config.hardKeyboardHidden:2
12-15 17:56:26.566: D/libEGL(23268): loaded /system/lib/egl/libGLES_android.so
12-15 17:56:26.566: D/libEGL(23268): loaded /system/lib/egl/libEGL_tegra.so
12-15 17:56:26.616: D/libEGL(23268): loaded /system/lib/egl/libGLESv1_CM_tegra.so
12-15 17:56:26.636: I/GeckoCrashReporter(23268): moving /data/data/org.mozilla.fennec/files/mozilla/i1u6s3du.default/minidumps/20b89db0-cee3-0a65-59e30301-6281b86a.dmp to /data/data/org.mozilla.fennec/files/mozilla/Crash Reports/pending/20b89db0-cee3-0a65-59e30301-6281b86a.dmp
12-15 17:56:26.646: D/libEGL(23268): loaded /system/lib/egl/libGLESv2_tegra.so
12-15 17:56:26.666: I/GeckoCrashReporter(23268): moving /data/data/org.mozilla.fennec/files/mozilla/i1u6s3du.default/minidumps/20b89db0-cee3-0a65-59e30301-6281b86a.extra to /data/data/org.mozilla.fennec/files/mozilla/Crash Reports/pending/20b89db0-cee3-0a65-59e30301-6281b86a.extra
12-15 17:56:26.666: W/dalvikvm(23268): threadid=8: thread exiting with uncaught exception (group=0x40111760)
12-15 17:56:26.666: D/dalvikvm(23268): GC_CONCURRENT freed 151K, 4% free 7612K/7879K, paused 12ms+11ms
12-15 17:56:26.676: E/GeckoCrashReporter(23268): exception while reading strings: 
12-15 17:56:26.676: E/GeckoCrashReporter(23268): java.lang.ArrayIndexOutOfBoundsException: Array index out of range: 1
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at java.util.regex.Matcher.appendEvaluated(Matcher.java:153)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at java.util.regex.Matcher.appendReplacement(Matcher.java:115)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at java.util.regex.Matcher.replaceAll(Matcher.java:322)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at java.lang.String.replaceAll(String.java:1890)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at org.mozilla.fennec.CrashReporter.unescape(CrashReporter.java:333)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at org.mozilla.fennec.CrashReporter.readStringsFromReader(CrashReporter.java:195)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at org.mozilla.fennec.CrashReporter.readStringsFromFile(CrashReporter.java:182)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at org.mozilla.fennec.CrashReporter.onCreate(CrashReporter.java:152)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at android.app.Activity.performCreate(Activity.java:4397)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1048)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1779)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:1831)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at android.app.ActivityThread.access$500(ActivityThread.java:122)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1024)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at android.os.Handler.dispatchMessage(Handler.java:99)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at android.os.Looper.loop(Looper.java:132)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at org.mozilla.gecko.GeckoApp$28.run(GeckoApp.java:1403)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at android.os.Handler.handleCallback(Handler.java:587)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at android.os.Handler.dispatchMessage(Handler.java:92)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at android.os.Looper.loop(Looper.java:132)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at android.app.ActivityThread.main(ActivityThread.java:4123)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at java.lang.reflect.Method.invokeNative(Native Method)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at java.lang.reflect.Method.invoke(Method.java:491)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:841)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:599)
12-15 17:56:26.676: E/GeckoCrashReporter(23268): 	at dalvik.system.NativeStart.main(Native Method)
12-15 17:56:26.686: E/AndroidRuntime(23268): FATAL EXCEPTION: GLThread 9
12-15 17:56:26.686: E/AndroidRuntime(23268): java.lang.IllegalArgumentException: Make sure the SurfaceView or associated SurfaceHolder has a valid Surface
12-15 17:56:26.686: E/AndroidRuntime(23268): 	at com.google.android.gles_jni.EGLImpl._eglCreateWindowSurface(Native Method)
12-15 17:56:26.686: E/AndroidRuntime(23268): 	at com.google.android.gles_jni.EGLImpl.eglCreateWindowSurface(EGLImpl.java:86)
12-15 17:56:26.686: E/AndroidRuntime(23268): 	at android.opengl.GLSurfaceView$DefaultWindowSurfaceFactory.createWindowSurface(GLSurfaceView.java:780)
12-15 17:56:26.686: E/AndroidRuntime(23268): 	at android.opengl.GLSurfaceView$EglHelper.createSurface(GLSurfaceView.java:1037)
12-15 17:56:26.686: E/AndroidRuntime(23268): 	at android.opengl.GLSurfaceView$GLThread.guardedRun(GLSurfaceView.java:1401)
12-15 17:56:26.686: E/AndroidRuntime(23268): 	at android.opengl.GLSurfaceView$GLThread.run(GLSurfaceView.java:1184)
12-15 17:56:26.696: W/ActivityManager(135):   Force finishing activity org.mozilla.fennec/.CrashReporter
12-15 17:56:26.866: D/dalvikvm(135): GC_FOR_ALLOC freed 613K, 20% free 26977K/33607K, paused 151ms
12-15 17:56:26.876: W/GeckoApp(23268): zerdatime 1323968186887 - pre checkLaunchState
12-15 17:56:26.876: I/GeckoApp(23268): Checking for an update
12-15 17:56:26.876: W/GeckoApp(23268): checking for an update took 0ms
12-15 17:56:26.876: D/StrictMode(23268): StrictMode policy violation; ~duration=212 ms: android.os.StrictMode$StrictModeDiskReadViolation: policy=31 violation=2
12-15 17:56:26.876: D/StrictMode(23268): 	at android.os.StrictMode$AndroidBlockGuardPolicy.onReadFromDisk(StrictMode.java:1067)
12-15 17:56:26.876: D/StrictMode(23268): 	at dalvik.system.BlockGuard$WrappedFileSystem.open(BlockGuard.java:235)
12-15 17:56:26.876: D/StrictMode(23268): 	at java.io.FileInputStream.<init>(FileInputStream.java:88)
12-15 17:56:26.876: D/StrictMode(23268): 	at java.io.FileInputStream.<init>(FileInputStream.java:122)
12-15 17:56:26.876: D/StrictMode(23268): 	at java.io.FileReader.<init>(FileReader.java:66)
12-15 17:56:26.876: D/StrictMode(23268): 	at org.mozilla.fennec.CrashReporter.readStringsFromFile(CrashReporter.java:181)
12-15 17:56:26.876: D/StrictMode(23268): 	at org.mozilla.fennec.CrashReporter.onCreate(CrashReporter.java:152)
12-15 17:56:26.876: D/StrictMode(23268): 	at android.app.Activity.performCreate(Activity.java:4397)
12-15 17:56:26.876: D/StrictMode(23268): 	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1048)
12-15 17:56:26.876: D/StrictMode(23268): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1779)
12-15 17:56:26.876: D/StrictMode(23268): 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:1831)
12-15 17:56:26.876: D/StrictMode(23268): 	at android.app.ActivityThread.access$500(ActivityThread.java:122)
12-15 17:56:26.876: D/StrictMode(23268): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1024)
12-15 17:56:26.876: D/StrictMode(23268): 	at android.os.Handler.dispatchMessage(Handler.java:99)
12-15 17:56:26.876: D/StrictMode(23268): 	at android.os.Looper.loop(Looper.java:132)
12-15 17:56:26.876: D/StrictMode(23268): 	at org.mozilla.gecko.GeckoApp$28.run(GeckoApp.java:1403)
12-15 17:56:26.876: D/StrictMode(23268): 	at android.os.Handler.handleCallback(Handler.java:587)
12-15 17:56:26.876: D/StrictMode(23268): 	at android.os.Handler.dispatchMessage(Handler.java:92)
12-15 17:56:26.876: D/StrictMode(23268): 	at android.os.Looper.loop(Looper.java:132)
12-15 17:56:26.876: D/StrictMode(23268): 	at android.app.ActivityThread.main(ActivityThread.java:4123)
12-15 17:56:26.876: D/StrictMode(23268): 	at java.lang.reflect.Method.invokeNative(Native Method)
12-15 17:56:26.876: D/StrictMode(23268): 	at java.lang.reflect.Method.invoke(Method.java:491)
12-15 17:56:26.876: D/StrictMode(23268): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:841)
12-15 17:56:26.876: D/StrictMode(23268): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:599)
12-15 17:56:26.876: D/StrictMode(23268): 	at dalvik.system.NativeStart.main(Native Method)
12-15 17:56:26.876: W/ActivityManager(135):   Force finishing activity org.mozilla.fennec/.App
12-15 17:56:26.886: D/StrictMode(23268): StrictMode policy violation; ~duration=208 ms: android.os.StrictMode$StrictModeDiskReadViolation: policy=31 violation=2
12-15 17:56:26.886: D/StrictMode(23268): 	at android.os.StrictMode$AndroidBlockGuardPolicy.onReadFromDisk(StrictMode.java:1067)
12-15 17:56:26.886: D/StrictMode(23268): 	at dalvik.system.BlockGuard$WrappedFileSystem.read(BlockGuard.java:171)
12-15 17:56:26.886: D/StrictMode(23268): 	at java.io.FileInputStream.read(FileInputStream.java:208)
12-15 17:56:26.886: D/StrictMode(23268): 	at java.io.InputStreamReader.read(InputStreamReader.java:248)
12-15 17:56:26.886: D/StrictMode(23268): 	at java.io.BufferedReader.fillBuf(BufferedReader.java:130)
12-15 17:56:26.886: D/StrictMode(23268): 	at java.io.BufferedReader.readLine(BufferedReader.java:357)
12-15 17:56:26.886: D/StrictMode(23268): 	at org.mozilla.fennec.CrashReporter.readStringsFromReader(CrashReporter.java:191)
12-15 17:56:26.886: D/StrictMode(23268): 	at org.mozilla.fennec.CrashReporter.readStringsFromFile(CrashReporter.java:182)
12-15 17:56:26.886: D/StrictMode(23268): 	at org.mozilla.fennec.CrashReporter.onCreate(CrashReporter.java:152)
12-15 17:56:26.886: D/StrictMode(23268): 	at android.app.Activity.performCreate(Activity.java:4397)
12-15 17:56:26.886: D/StrictMode(23268): 	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1048)
12-15 17:56:26.886: D/StrictMode(23268): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1779)
12-15 17:56:26.886: D/StrictMode(23268): 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:1831)
12-15 17:56:26.886: D/StrictMode(23268): 	at android.app.ActivityThread.access$500(ActivityThread.java:122)
12-15 17:56:26.886: D/StrictMode(23268): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1024)
12-15 17:56:26.886: D/StrictMode(23268): 	at android.os.Handler.dispatchMessage(Handler.java:99)
12-15 17:56:26.886: D/StrictMode(23268): 	at android.os.Looper.loop(Looper.java:132)
12-15 17:56:26.886: D/StrictMode(23268): 	at org.mozilla.gecko.GeckoApp$28.run(GeckoApp.java:1403)
12-15 17:56:26.886: D/StrictMode(23268): 	at android.os.Handler.handleCallback(Handler.java:587)
12-15 17:56:26.886: D/StrictMode(23268): 	at android.os.Handler.dispatchMessage(Handler.java:92)
12-15 17:56:26.886: D/StrictMode(23268): 	at android.os.Looper.loop(Looper.java:132)
12-15 17:56:26.886: D/StrictMode(23268): 	at android.app.ActivityThread.main(ActivityThread.java:4123)
12-15 17:56:26.886: D/StrictMode(23268): 	at java.lang.reflect.Method.invokeNative(Native Method)
12-15 17:56:26.886: D/StrictMode(23268): 	at java.lang.reflect.Method.invoke(Method.java:491)
12-15 17:56:26.886: D/StrictMode(23268): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:841)
12-15 17:56:26.886: D/StrictMode(23268): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:599)
12-15 17:56:26.886: D/StrictMode(23268): 	at dalvik.system.NativeStart.main(Native Method)
12-15 17:56:26.926: D/WindowManager(135): adjustConfigurationLw, config:{1.0 0mcc0mnc (no locale) sw800dp w1280dp h752dp xlrg land ?uimode ?night finger -keyb/v/h -nav/v} mLidOpen:-1 mHasDockFeature:true mHasHallSensorFeature:true config.hardKeyboardHidden:2
12-15 17:56:27.086: D/dalvikvm(23268): GC_CONCURRENT freed 269K, 5% free 7814K/8199K, paused 3ms+7ms
12-15 17:56:27.086: E/StrictMode(23268): A resource was acquired at attached stack trace but never released. See java.io.Closeable for information on avoiding resource leaks.
12-15 17:56:27.086: E/StrictMode(23268): java.lang.Throwable: Explicit termination method 'close' not called
12-15 17:56:27.086: E/StrictMode(23268): 	at dalvik.system.CloseGuard.open(CloseGuard.java:187)
12-15 17:56:27.086: E/StrictMode(23268): 	at java.io.FileInputStream.<init>(FileInputStream.java:90)
12-15 17:56:27.086: E/StrictMode(23268): 	at org.mozilla.gecko.AboutHomeContent.getProfileRecommendedAddonsStream(AboutHomeContent.java:226)
12-15 17:56:27.086: E/StrictMode(23268): 	at org.mozilla.gecko.AboutHomeContent.getRecommendedAddonsStream(AboutHomeContent.java:234)
12-15 17:56:27.086: E/StrictMode(23268): 	at org.mozilla.gecko.AboutHomeContent$6.run(AboutHomeContent.java:252)
12-15 17:56:27.086: E/StrictMode(23268): 	at android.os.Handler.handleCallback(Handler.java:587)
12-15 17:56:27.086: E/StrictMode(23268): 	at android.os.Handler.dispatchMessage(Handler.java:92)
12-15 17:56:27.086: E/StrictMode(23268): 	at android.os.Looper.loop(Looper.java:132)
12-15 17:56:27.086: E/StrictMode(23268): 	at org.mozilla.gecko.GeckoAppShell$LooperThread.run(GeckoAppShell.java:153)
12-15 17:56:27.096: E/StrictMode(23268): A resource was acquired at attached stack trace but never released. See java.io.Closeable for information on avoiding resource leaks.
12-15 17:56:27.096: E/StrictMode(23268): java.lang.Throwable: Explicit termination method 'close' not called
12-15 17:56:27.096: E/StrictMode(23268): 	at dalvik.system.CloseGuard.open(CloseGuard.java:187)
12-15 17:56:27.096: E/StrictMode(23268): 	at java.io.FileInputStream.<init>(FileInputStream.java:90)
12-15 17:56:27.096: E/StrictMode(23268): 	at java.io.FileInputStream.<init>(FileInputStream.java:122)
12-15 17:56:27.096: E/StrictMode(23268): 	at java.io.FileReader.<init>(FileReader.java:66)
12-15 17:56:27.096: E/StrictMode(23268): 	at org.mozilla.fennec.CrashReporter.readStringsFromFile(CrashReporter.java:181)
12-15 17:56:27.096: E/StrictMode(23268): 	at org.mozilla.fennec.CrashReporter.onCreate(CrashReporter.java:152)
12-15 17:56:27.096: E/StrictMode(23268): 	at android.app.Activity.performCreate(Activity.java:4397)
12-15 17:56:27.096: E/StrictMode(23268): 	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1048)
12-15 17:56:27.096: E/StrictMode(23268): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1779)
12-15 17:56:27.096: E/StrictMode(23268): 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:1831)
12-15 17:56:27.096: E/StrictMode(23268): 	at android.app.ActivityThread.access$500(ActivityThread.java:122)
12-15 17:56:27.096: E/StrictMode(23268): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1024)
12-15 17:56:27.096: E/StrictMode(23268): 	at android.os.Handler.dispatchMessage(Handler.java:99)
12-15 17:56:27.096: E/StrictMode(23268): 	at android.os.Looper.loop(Looper.java:132)
12-15 17:56:27.096: E/StrictMode(23268): 	at org.mozilla.gecko.GeckoApp$28.run(GeckoApp.java:1403)
12-15 17:56:27.096: E/StrictMode(23268): 	at android.os.Handler.handleCallback(Handler.java:587)
12-15 17:56:27.096: E/StrictMode(23268): 	at android.os.Handler.dispatchMessage(Handler.java:92)
12-15 17:56:27.096: E/StrictMode(23268): 	at android.os.Looper.loop(Looper.java:132)
12-15 17:56:27.096: E/StrictMode(23268): 	at android.app.ActivityThread.main(ActivityThread.java:4123)
12-15 17:56:27.096: E/StrictMode(23268): 	at java.lang.reflect.Method.invokeNative(Native Method)
12-15 17:56:27.096: E/StrictMode(23268): 	at java.lang.reflect.Method.invoke(Method.java:491)
12-15 17:56:27.096: E/StrictMode(23268): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:841)
12-15 17:56:27.096: E/StrictMode(23268): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:599)
12-15 17:56:27.096: E/StrictMode(23268): 	at dalvik.system.NativeStart.main(Native Method)
12-15 17:56:27.166: I/GeckoApp(23268): stop
12-15 17:56:27.226: D/dalvikvm(23268): GC_EXPLICIT freed 141K, 6% free 7772K/8199K, paused 6ms+2ms
12-15 17:56:27.246: I/GeckoApp(23268): destroy
12-15 17:56:27.246: D/GeckoFavicons(23268): Closing Favicons database
12-15 17:56:27.306: I/ActivityManager(135): Displayed org.mozilla.fennec/.CrashReporter: +786ms (total +1s241ms)
12-15 17:56:27.316: D/dalvikvm(23268): GC_EXPLICIT freed 3K, 6% free 7770K/8199K, paused 2ms+4ms
12-15 17:56:27.466: D/dalvikvm(23268): GC_EXPLICIT freed 66K, 7% free 7704K/8199K, paused 3ms+4ms
Attached file second logcat of crash
Attachment #582001 - Attachment is obsolete: true
Attached patch patchSplinter Review
Attachment #582088 - Flags: review?(mark.finkle)
Assignee: nobody → blassey.bugs
Comment on attachment 582088 [details] [diff] [review]
patch


>             titleView.setText(name);
>             urlView.setText(searchText);
>-            faviconView.setImageDrawable(getDrawableFromDataURI(iconURI));
>+            Drawable drawable = getDrawableFromDataURI(iconURI);
>+            faviconView.setImageDrawable(drawable);

Does creating the local do anything impicitly?
Attachment #582088 - Flags: review?(mark.finkle) → review+
(In reply to Mark Finkle (:mfinkle) from comment #11)
> Comment on attachment 582088 [details] [diff] [review]
> patch
> 
> 
> >             titleView.setText(name);
> >             urlView.setText(searchText);
> >-            faviconView.setImageDrawable(getDrawableFromDataURI(iconURI));
> >+            Drawable drawable = getDrawableFromDataURI(iconURI);
> >+            faviconView.setImageDrawable(drawable);
> 
> Does creating the local do anything impicitly?

my intention was to null check it. I'll add that when I land
pushed https://hg.mozilla.org/integration/mozilla-inbound/rev/7d11de2fdbc2
Whiteboard: [native-crash] → [native-crash][inbound]
https://hg.mozilla.org/mozilla-central/rev/7d11de2fdbc2
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [native-crash][inbound] → [native-crash]
You need to log in before you can comment on or make changes to this bug.