If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

View Source appears to resubmit a form without data

VERIFIED DUPLICATE of bug 64100

Status

()

Core
HTML: Form Submission
VERIFIED DUPLICATE of bug 64100
17 years ago
17 years ago

People

(Reporter: Damien, Assigned: rods (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.18pre21 i686; en-US; 0.9) Gecko/20010303
BuildID:    2001030321

View Source on the html generated from a cgi appears to resubmit the CGI without
the data from the original submission rather than pulling it from the cache.

Reproducible: Always
Steps to Reproduce:
Go to http://www.buseco.monash.edu.au/People/
Fill in the form on the right with "andrew"
When the CGI has returned the matching names, go to View Source.
Look at the title (in the 1st few lines of the source) - it says
"Search string too short" which is the response that putting in a
blank input will return.

Actual Results:  Appears to resubmit form

Expected Results:  Get source from the cache

Only tested it with post method, not get
Duplicate of "view-source doesn't work for pages generated via forms with
method=POST"

*** This bug has been marked as a duplicate of 64100 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Verified! This bug is indeed a duplicate of 64100 - view-source doesn't work for
pages generated via forms with method=POST
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.