inspector highlights SVG foreignObject elements at wrong position

RESOLVED FIXED

Status

()

Firefox
Developer Tools: Inspector
--
minor
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: David A. Madore, Unassigned)

Tracking

10 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Comment hidden (empty)
(Reporter)

Comment 1

6 years ago
(Sorry, I submitted the bug before adding a description.  Here it is:)

The new Firefox inspector in the dev tools highlights elements inside an SVG foreignObject at the wrong position when the foreignObject is subject to a coordinate transform.

To reproduce: load the page <URL: http://www.madore.org/~david/.tmp/foreignobjtest.html >, right-click on one of the elements of the embedded text to inspect it: the highlight is wrongly positioned.

Comment 2

6 years ago
This should be fixed now. Can you please confirm?
(Reporter)

Comment 3

6 years ago
Yes, it seems to be fixed in the 12 branch.  (I don't suppose there's any chance of the fix being backported to Aurora?)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.