Last Comment Bug 709888 - Remove UA switcher
: Remove UA switcher
Status: VERIFIED FIXED
[mtd]
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P1 normal (vote)
: Firefox 12
Assigned To: Brian Nicholson (:bnicholson)
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-12 11:22 PST by Lawrence Mandel [:lmandel] (use needinfo)
Modified: 2016-07-29 14:21 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
verified
11+


Attachments
patch v.1 (12.10 KB, patch)
2012-01-06 14:36 PST, Doug Turner (:dougt)
mark.finkle: review-
Details | Diff | Splinter Review
patch v2 (21.12 KB, patch)
2012-01-09 12:56 PST, Brian Nicholson (:bnicholson)
mark.finkle: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Lawrence Mandel [:lmandel] (use needinfo) 2011-12-12 11:22:58 PST
The Request Desktop Site option is not applicable for many pages:

- sites that only have desktop content
- sites that do not recognize Firefox mobile and return the desktop content
- mobiles sites that I explicitly navigate to (for ex. open m.imdb.com in your browser) (because Firefox gets the desktop sites by default)
- about: pages

While I like the idea of being able to request the desktop vs mobile version of a site and would find this option useful if it worked reliably, I do not find this option useful today. At this point I think the option just adds a source of confusion to the browser (and affects the browser polish as the option appears to do nothing on many sites). I would like to suggest that this option should be removed from the menu until such time that it is generally applicable when browsing in Firefox mobile.
Comment 1 Kevin Brosnan [:kbrosnan] 2011-12-13 12:59:50 PST
bug 706264 is about redirects to mobiles sites breaking 'request desktop site'. From my brief look into Android browsers it seems that most implement this as a global option or a set of sites to use a a specific UA with.
Comment 2 Asa Dotzler [:asa] 2011-12-17 12:27:12 PST
I agree with Lawrence. It fails often enough that it's more frustrating to have it than to not. This feature really ought to be removed because it's just not reliable enough.
Comment 3 Doug Turner (:dougt) 2011-12-19 13:27:55 PST
I think we should hide/remove this feature.
Comment 4 Doug Turner (:dougt) 2012-01-06 14:36:10 PST
Created attachment 586573 [details] [diff] [review]
patch v.1
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-06 14:46:29 PST
Comment on attachment 586573 [details] [diff] [review]
patch v.1

We do want to remove the feature. I talked to Brian about removing it all. Even the part in browser.js
Comment 6 Brian Nicholson (:bnicholson) 2012-01-09 12:56:47 PST
Created attachment 587090 [details] [diff] [review]
patch v2
Comment 7 Brian Nicholson (:bnicholson) 2012-01-12 12:27:29 PST
Landed on mozilla-inbound:
http://hg.mozilla.org/integration/mozilla-inbound/rev/c04fb55118f8
Comment 8 Marco Bonardo [::mak] 2012-01-13 02:54:46 PST
https://hg.mozilla.org/mozilla-central/rev/c04fb55118f8
Comment 9 Aaron Train [:aaronmt] 2012-01-13 07:39:26 PST
Comment on attachment 587090 [details] [diff] [review]
patch v2

[Approval Request Comment]
Removal of the feature on Aurora
Comment 10 Aaron Train [:aaronmt] 2012-01-13 07:40:02 PST
Verified on Nightly (12.0a1)
Samsung Nexus S (Android 4.0.3)
20120113052739
http://hg.mozilla.org/mozilla-central/rev/790cd9bba7f5
Comment 11 Alex Keybl [:akeybl] 2012-01-16 13:00:38 PST
Comment on attachment 587090 [details] [diff] [review]
patch v2

[Triage Comment]
Mobile only - approved for Aurora.
Comment 12 Brad Lassey [:blassey] (use needinfo?) 2012-01-20 13:52:01 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/22710663cf24

Note You need to log in before you can comment on or make changes to this bug.