Change "Preferences" strings to "Settings"

VERIFIED FIXED in Firefox 11

Status

()

Firefox for Android
General
P3
normal
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: cpeterson, Assigned: mbrubeck)

Tracking

({polish})

unspecified
Firefox 11
ARM
Android
polish
Points:
---

Firefox Tracking Flags

(firefox11 verified, firefox12 verified, fennec11+)

Details

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

6 years ago
Fennec has a "Preferences" menu, but EVERY other Android app and the OS use the term "Settings". We should probably follow their example.
(Reporter)

Comment 1

6 years ago
For comparison, Firefox on uses the term "Options" on Windows and "Preferences" on Mac.
/summon UX
Madhava and I were talking about this last week, and agree that we should call it Settings on Android.
(Assignee)

Comment 4

6 years ago
Should we also change "Clear Site Preferences" (in the site options) and "Search Preferences" (in the search field on about:config)?
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
Yes, please.

Updated

6 years ago
Keywords: polish
Priority: -- → P3
(Assignee)

Comment 6

6 years ago
Created attachment 582963 [details] [diff] [review]
patch
Attachment #582963 - Flags: review?(cpeterson)
(Assignee)

Comment 7

6 years ago
Created attachment 582964 [details] [diff] [review]
clean up unused strings

While working on this, I found we had a bunch of dead strings that made it hard to find all the places to change.  This patch removes them along with some dead files that referenced them.
Attachment #582964 - Flags: review?(mark.finkle)
(Reporter)

Comment 8

6 years ago
Comment on attachment 582963 [details] [diff] [review]
patch

Review of attachment 582963 [details] [diff] [review]:
-----------------------------------------------------------------

1. Why not change gecko_menu.xml's "@+id/preferences" to "@+id/settings", too? You would need to change code references to |R.id.preferences| to |R.id.settings|.

2. Where is the prefsHeaders.label string (from mobile/android/locales/en-US/chrome/preferences.dtd) used? Should its value be changed to "Settings" too?
(Assignee)

Comment 9

6 years ago
Created attachment 583005 [details] [diff] [review]
patch

(In reply to Chris Peterson (:cpeterson) from comment #8)
> 1. Why not change gecko_menu.xml's "@+id/preferences" to "@+id/settings",
> too? You would need to change code references to |R.id.preferences| to
> |R.id.settings|.

Sounds like a good idea.  Updated.

> 2. Where is the prefsHeaders.label string (from
> mobile/android/locales/en-US/chrome/preferences.dtd) used? Should its value
> be changed to "Settings" too?

This is unused (left over from XUL Fennec); I'll post a patch to remove it.
Attachment #582963 - Attachment is obsolete: true
Attachment #582963 - Flags: review?(cpeterson)
Attachment #583005 - Flags: review?(cpeterson)
(Assignee)

Comment 10

6 years ago
Created attachment 583013 [details] [diff] [review]
clean up unused strings

Updated to remove unused strings from preferences.dtd.
Attachment #582964 - Attachment is obsolete: true
Attachment #582964 - Flags: review?(mark.finkle)
Attachment #583013 - Flags: review?(mark.finkle)
Comment on attachment 583013 [details] [diff] [review]
clean up unused strings

perhaps you could rename preferences.dtd -> aboutHome.dtd? is it used anywhere else?
Attachment #583013 - Flags: review?(mark.finkle) → review+
(Reporter)

Comment 12

6 years ago
Comment on attachment 583005 [details] [diff] [review]
patch

Review of attachment 583005 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good.
Attachment #583005 - Flags: review?(cpeterson) → review+
(Assignee)

Comment 13

6 years ago
https://hg.mozilla.org/mozilla-central/rev/05720c79f740
https://hg.mozilla.org/mozilla-central/rev/c7101dec8deb
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 14

6 years ago
Retested with:
Mozilla/5.0 (Android; Linux armv7l; rv:11.0a1) Gecko/20111221 Firefox/11.0a1 Fennec/11.0a1
HTC Desire Z (Android 2.3)

"Settings" string is used in the Fennec Menu.

But in about:config still "Search Preferences" and "Add new Preference" strings are used.

Per comment4 and comment5 this strings should also be changed.

Reopening bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 15

6 years ago
Created attachment 583532 [details] [diff] [review]
patch

Oops, I missed that part.  Thanks!  Here's the fix.
Attachment #583532 - Flags: review?(mark.finkle)
Attachment #583532 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 16

6 years ago
Follow-up pushed to inbound; this bug can be resolved fixed when this is merged to mozilla-central.
https://hg.mozilla.org/integration/mozilla-inbound/rev/04efeb587d1b

The main patch landed for Firefox 11, but the follow-up is only in Firefox 12.  Since the follow-up only affects about:config, I don't think it's important to land it in Aurora.
Status: REOPENED → ASSIGNED
Target Milestone: --- → Firefox 11
https://hg.mozilla.org/mozilla-central/rev/04efeb587d1b
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
tracking-fennec: --- → 11+
status-firefox11: --- → affected
status-firefox12: --- → fixed
(Assignee)

Updated

6 years ago
status-firefox11: affected → fixed

Comment 18

6 years ago
Retested with:
12.0a1 (2012-01-10) HTC Desire Z (Android 2.3)

Bug no longer reproducible. In about:config Settings string is used.
status-firefox12: fixed → verified

Comment 19

6 years ago
Verified on Aurora 11.0a2 (2012-01-17):

In about:config still "Search Preferences" and "Add new Preference" strings are used.
status-firefox11: fixed → affected
Carla - I assume you meant to set the flag to "verified"
status-firefox11: affected → verified

Comment 21

6 years ago
No, bug is not yet fixed on Aurora.

On Nightly instead of "Search Preferences" and "Add new Preference" we use "Search settings" and "Add a new Setting"
status-firefox11: verified → affected
Comment on attachment 583532 [details] [diff] [review]
patch

[Approval Request Comment]
This patch did not make it into aurora with the initial merge.
Attachment #583532 - Flags: approval-mozilla-aurora?
Comment on attachment 583532 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for aurora.
Attachment #583532 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 24

6 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/f5eef1b7d636
status-firefox11: affected → fixed

Comment 25

6 years ago
Verified on:
Nightly Fennec 12.0a1 (2012-01-19) 
Samsung Google Nexus S( Android 2.3.6)
Status: RESOLVED → VERIFIED
status-firefox11: fixed → verified
You need to log in before you can comment on or make changes to this bug.