Last Comment Bug 709971 - reflow telemetry
: reflow telemetry
Status: RESOLVED FIXED
[Snappy:P1]
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla12
Assigned To: Nathan Froyd [:froydnj]
:
Mentors:
Depends on: 681535
Blocks: 683180
  Show dependency treegraph
 
Reported: 2011-12-12 14:27 PST by (dormant account)
Modified: 2012-01-12 08:33 PST (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
HTML reflow telemetry (1.70 KB, patch)
2012-01-10 10:20 PST, Nathan Froyd [:froydnj]
no flags Details | Diff | Review
HTML reflow telemetry (1.76 KB, patch)
2012-01-10 10:26 PST, Nathan Froyd [:froydnj]
bzbarsky: review+
Details | Diff | Review

Description (dormant account) 2011-12-12 14:27:24 PST
Bug 681535 added xul telemetry. Lets also add html reflow telemetry. This time do not report 0ms reflows. We need this to see how often we encounter pages that stall the browser in layout.
Comment 1 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-12-12 14:37:01 PST
I'd appreciate it if you build on top of the patches in bug 709256!
Comment 2 Nathan Froyd [:froydnj] 2011-12-13 12:33:04 PST
Is it worth doing something like what we did in bug 699051 by sending back URLs that take longer than $MAX_TIME in reflow?  (Possibly with MAX_TIME calculated based on some timing cleverness.)

Obviously there are significant privacy implications to doing that, but I'm not sure knowing "hey, 5% of pages stall the browser for longer than 5s" is going to help us that much, as we don't have STR from that data.  Willing to be corrected by the layout guys!
Comment 3 (dormant account) 2011-12-13 18:35:52 PST
(In reply to Nathan Froyd (:froydnj) from comment #2)
> Is it worth doing something like what we did in bug 699051 by sending back
> URLs that take longer than $MAX_TIME in reflow?  (Possibly with MAX_TIME
> calculated based on some timing cleverness.)

It would be cool, but sending back URL(or anything related to URL) is not going to fly
Comment 4 (dormant account) 2011-12-13 18:36:39 PST
Also good point about 5% of pages, can't skip 0ms reflows in this case.
Comment 5 Nathan Froyd [:froydnj] 2011-12-16 12:02:18 PST
(In reply to Taras Glek (:taras) from comment #3)
> (In reply to Nathan Froyd (:froydnj) from comment #2)
> > Is it worth doing something like what we did in bug 699051 by sending back
> > URLs that take longer than $MAX_TIME in reflow?  (Possibly with MAX_TIME
> > calculated based on some timing cleverness.)
> 
> It would be cool, but sending back URL(or anything related to URL) is not
> going to fly

OK, then what can we do once these numbers are in hand?  Plot them for Talos (or similar measures) tests?  I'm not seeing how having just reflow ms in isolation is going to help us.
Comment 6 Nathan Froyd [:froydnj] 2012-01-10 10:20:40 PST
Created attachment 587363 [details] [diff] [review]
HTML reflow telemetry

Simple enough, I guess.
Comment 7 Nathan Froyd [:froydnj] 2012-01-10 10:26:41 PST
Created attachment 587365 [details] [diff] [review]
HTML reflow telemetry
Comment 8 Boris Zbarsky [:bz] (Out June 25-July 6) 2012-01-10 11:41:36 PST
Comment on attachment 587365 [details] [diff] [review]
HTML reflow telemetry

r=me
Comment 9 (dormant account) 2012-01-10 12:19:57 PST
Boris, how hard would it be to track reflow in background tabs?
Comment 10 Boris Zbarsky [:bz] (Out June 25-July 6) 2012-01-10 12:28:16 PST
In what sense?  The presshell knows whether it's in a background tab....
Comment 11 (dormant account) 2012-01-10 13:19:27 PST
(In reply to Boris Zbarsky (:bz) from comment #10)
> In what sense?  The presshell knows whether it's in a background tab....

that's what I wanted. I would like to know how much jank is caused by reflows in background tabs
Comment 12 Boris Zbarsky [:bz] (Out June 25-July 6) 2012-01-10 13:47:48 PST
The mIsActive member of presshell should be what you want, then.  Presumably just log reflows when !mIsActive to a separate histogram?
Comment 14 Matt Brubeck (:mbrubeck) 2012-01-12 08:33:29 PST
https://hg.mozilla.org/mozilla-central/rev/103460516db6

Note You need to log in before you can comment on or make changes to this bug.