Last Comment Bug 709977 - Don't use xpc_qsAString in IDB Key.h
: Don't use xpc_qsAString in IDB Key.h
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla11
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks: 692669
  Show dependency treegraph
 
Reported: 2011-12-12 14:46 PST by :Ms2ger (⌚ UTC+1/+2)
Modified: 2011-12-18 07:25 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (1.07 KB, patch)
2011-12-12 14:46 PST, :Ms2ger (⌚ UTC+1/+2)
bent.mozilla: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2011-12-12 14:46:29 PST
Created attachment 581063 [details] [diff] [review]
Patch v1

SetFromJSVal is currently the only user of xpc_qsAString outside of XPConnect.

Except for the additional API exposed, there are two problems with that. First, we don't check if IsValid() before using the string, which could (if I'm not mistaken, I may be) lead to dereferencing uninitialized memory in case of OOM, and second, there's really no need to invoke all the generic value -> string conversion code, because we already know we've got a string.

Fortunately, it can easily be replaced by nsDependentJSString.
Comment 1 :Ms2ger (⌚ UTC+1/+2) 2011-12-18 07:25:05 PST
https://hg.mozilla.org/mozilla-central/rev/d6a97d9eb14b

Note You need to log in before you can comment on or make changes to this bug.