Closed Bug 710065 Opened 8 years ago Closed 7 years ago

[traceback] [prod] Exception: TypeError: int() argument must be a string or a number, not 'NoneType'

Categories

(Input Graveyard :: Backend, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mbrandt, Unassigned)

References

()

Details

/en-US/feedback

POST:<QueryDict: {u'device': [u''], u'_typePr': [u''], u'description': [u'INTERNETEXPLOWER\r\n\r\n\r\n\r\n\r\n\r\n'], u'manufacturer': [u'']}>,

Traceback (most recent call last):

 File "/data/www/django/input.mozilla.com/reporter/vendor/src/django/django/core/handlers/base.py", line 111, in get_response
   response = callback(request, *callback_args, **callback_kwargs)

 File "/data/www/django/input.mozilla.com/reporter/apps/input/decorators.py", line 102, in wrapped
   return f(request, *args, **kwargs)

 File "/data/www/django/input.mozilla.com/reporter/apps/feedback/views.py", line 52, in wrapped
   return f(request, ua=ua, *args, **kwargs)

 File "/data/www/django/input.mozilla.com/reporter/vendor/src/django/django/views/decorators/cache.py", line 79, in _wrapped_view_func
   response = view_func(request, *args, **kwargs)

 File "/data/www/django/input.mozilla.com/reporter/apps/feedback/views.py", line 65, in feedback
   typ = int(request.POST.get('_type'))

TypeError: int() argument must be a string or a number, not 'NoneType'
Confirmed and still present. On the upside, sounds like an easy fix.
Sorry for the bugspam, but the I did a checkin https://hg.mozilla.org/comm-central/rev/46a016210d50 that inadvertently pointed to this bug, when the correct bug should have been bug 710056.
I cannot reproduce with

curl -L -A 'User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/20100101 Firefox/19.0' -d 'device=&_typePr=&description=INTERNETEXPLOWER\r\n\r\n\r\n\r\n\r\n\r\n&manufacturer=' http://input.mozilla.com/en-US/feedback

This seems fixed.
This is definitely fixed now. I hated this bug sooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo much I want to resolve it as DIEDINAFIERYHELL, but FIXED is good enough.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Hell's Bells! Nicely done!

QA verified DIEDINAFIERYHELL
Status: RESOLVED → VERIFIED
OS: Mac OS X → All
Hardware: x86 → All
Product: Input → Input Graveyard
You need to log in before you can comment on or make changes to this bug.