[RFE] Account Wizard should allow setting of different SMTP server

ASSIGNED

Status

SeaMonkey
MailNews: Account Configuration
--
enhancement
ASSIGNED
17 years ago
5 years ago

People

(Reporter: Gregor Rosenauer, Assigned: neil@parkwaycc.co.uk)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 4 obsolete attachments)

(Reporter)

Description

17 years ago
See also bug #52384.

Currently, when you set up a new POP-account, the default outgoing server is used.
This violates the new mailserver-rules which deny "relaying" and only accept
mail from people who are registered on that server.
This was introduced (at least over here in Europe) after spammers misused
various mailservers to send out unsolicited mass-mail.

So, instead of hiding away the possibility to add another SMTP-server, this
should be made available in the account-wizard right away.
Currently, a message is displayed that it's best to use the default-server, and
the user has no choice to specify his or her own.

Comment 1

17 years ago
See also bug #49893

Comment 2

16 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: ui
Summary: Accountmanager should assume seperate SMTP-server for each account → [RFE] Account Wizard should allow setting of different SMTP server

Comment 3

15 years ago
This is definitly needed.  If you have more than one email account in mozilla
you have to switch the smtp server manualy when you want to send email.
mass re-assign.
Assignee: racham → sspitzer
found dupe, marking this the dupe as the other has more details.

*** This bug has been marked as a duplicate of 170520 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 6

14 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
(Assignee)

Comment 7

5 years ago
Created attachment 596499 [details] [diff] [review]
Rearrange fields

The first stage is to switch from server/login pages to incoming/outgoing pages. This patch just does what I think are all the code changes. In particular, I'm going to have to do something about the access keys. For now, I
* renamed the server page to the incoming page and the login page to the outgoing page.
* moved the SMTP server box to the outgoing page and the POP/IMAP username box to the incoming page, including the setup and validation code.
I've tried this with regular email accounts. As far as I can tell it doesn't affect news accounts, but I don't have any ispdata accounts to test with.
Assignee: sspitzer → neil
Status: VERIFIED → REOPENED
Attachment #596499 - Flags: feedback?(iann_bugzilla)
Attachment #596499 - Flags: feedback?(dbienvenu)
Resolution: DUPLICATE → ---

Comment 8

5 years ago
Comment on attachment 596499 [details] [diff] [review]
Rearrange fields

thunderbird build failed because it couldn't find aw-server.js - I didn't do a clobber build, but I suspect there's still a TB reference to that file. I'll investigate a bit later.

Comment 9

5 years ago
Created attachment 597292 [details] [diff] [review]
patch that builds for Thunderbird

this builds on Thunderbird - will try it in the morning.
(Assignee)

Comment 10

5 years ago
Oh, I forgot to include jar.mn changes in my diff. Sorry about that.
(Assignee)

Comment 11

5 years ago
Created attachment 597337 [details] [diff] [review]
With correct jar.mn changes
Attachment #596499 - Attachment is obsolete: true
Attachment #597292 - Attachment is obsolete: true
Attachment #596499 - Flags: feedback?(iann_bugzilla)
Attachment #596499 - Flags: feedback?(dbienvenu)
Attachment #597337 - Flags: feedback?(iann_bugzilla)
(Assignee)

Comment 12

5 years ago
Comment on attachment 597337 [details] [diff] [review]
With correct jar.mn changes

Bah, I tried to request dbienvenu when I should have used :bienvenu...
Attachment #597337 - Flags: feedback?(dbienvenu)

Comment 13

5 years ago
Thunderbird doesn't use the account wizard for new mail accounts, but it does use it for new news accounts, and when I try to add a new news account, after giving the nntp host name, I get this:

AccountWizard.prefillAccountForIsp(newsaccount)
JavaScript error: chrome://messenger/content/AccountWizard.xul, line 1: incoming
PageValidate is not defined

I haven't tried this w/o your patch, and I haven't made sure that I made the same jar changes as your most recent patch - I'll check that now.
(Assignee)

Comment 14

5 years ago
(In reply to David Bienvenu from comment #13)
> Thunderbird doesn't use the account wizard for new mail accounts
Have you dropped the preconfigured accounts you used to have too?

> incomingPageValidate is not defined
That should be defined in aw-incoming.js for which you would need the latest jar.mn changes to package correctly.

Comment 15

5 years ago
(In reply to neil@parkwaycc.co.uk from comment #14)
> (In reply to David Bienvenu from comment #13)
> > Thunderbird doesn't use the account wizard for new mail accounts
> Have you dropped the preconfigured accounts you used to have too?

yes, since we can do the same thing with the autoconfig stuff.
> 
> > incomingPageValidate is not defined
> That should be defined in aw-incoming.js for which you would need the latest
> jar.mn changes to package correctly.

that was it - setting up a new news account does work.

Updated

5 years ago
Attachment #597337 - Flags: feedback?(dbienvenu) → feedback+

Comment 16

5 years ago
Comment on attachment 597337 [details] [diff] [review]
With correct jar.mn changes

You've not changed serverTitle.label or loginTitle.label to incoming / outgoing.
f+ from me on testing mail accounts (though not every iteration possible).
Attachment #597337 - Flags: feedback?(iann_bugzilla) → feedback+
(Assignee)

Comment 17

5 years ago
Created attachment 598710 [details] [diff] [review]
Now with string changes

Although patch didn't like it, kdiff3 seemed to think it could merge the locale changes to Thunderbird, so I hope it's OK.

This patch also includes a bugfix for a missing smtp user name which was supposed to default to copying the incoming user name.

I tried not to rename too many entities.
Attachment #597337 - Attachment is obsolete: true
Attachment #598710 - Flags: review?(iann_bugzilla)
Attachment #598710 - Flags: feedback?(dbienvenu)

Comment 18

5 years ago
Comment on attachment 598710 [details] [diff] [review]
Now with string changes

adding TB news accounts works fine.
Attachment #598710 - Flags: feedback?(dbienvenu) → feedback+

Updated

5 years ago
Status: REOPENED → ASSIGNED

Comment 19

5 years ago
Comment on attachment 598710 [details] [diff] [review]
Now with string changes

The xul parts you are touching which are over 80 characters long, could you make them one attribute per line?
r=me either way.
Attachment #598710 - Flags: review?(iann_bugzilla) → review+

Comment 20

5 years ago
Comment on attachment 598710 [details] [diff] [review]
Now with string changes

Hmmm, on further testing, the wizard for newsblog accounts is not correct.
It prompts for both incoming and outgoing information which it shouldn't.
Attachment #598710 - Flags: review+ → review-
(Assignee)

Comment 21

5 years ago
Created attachment 601623 [details] [diff] [review]
Fix RSS

Also fixes a bug in the global inbox code whereby it is offered for movemail.
Attachment #598710 - Attachment is obsolete: true
Attachment #601623 - Flags: review?(iann_bugzilla)
Attachment #601623 - Flags: review?(dbienvenu)

Comment 22

5 years ago
Comment on attachment 601623 [details] [diff] [review]
Fix RSS

r=me thanks
Attachment #601623 - Flags: review?(iann_bugzilla) → review+

Updated

5 years ago
QA Contact: esther → mailnews-account

Comment 23

5 years ago
Comment on attachment 601623 [details] [diff] [review]
Fix RSS

add an rss account in TB works w/ this patch.
Attachment #601623 - Flags: review?(dbienvenu) → review+
(Assignee)

Comment 24

5 years ago
Comment on attachment 601623 [details] [diff] [review]
Fix RSS

Pushed changeset 0935f4dd69c4 to comm-central.
You need to log in before you can comment on or make changes to this bug.