Last Comment Bug 710098 - "ASSERTION: vertical damage extends outside table" with changing colspan
: "ASSERTION: vertical damage extends outside table" with changing colspan
Status: RESOLVED FIXED
: assertion, testcase
Product: Core
Classification: Components
Component: Layout: Tables (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- normal (vote)
: mozilla12
Assigned To: Bernd
:
Mentors:
Depends on:
Blocks: stirtable
  Show dependency treegraph
 
Reported: 2011-12-12 17:56 PST by Jesse Ruderman
Modified: 2011-12-30 05:06 PST (History)
3 users (show)
bernd_mozilla: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (200 bytes, text/html)
2011-12-12 17:56 PST, Jesse Ruderman
no flags Details
stack trace (3.08 KB, text/plain)
2011-12-12 17:56 PST, Jesse Ruderman
no flags Details
patch (1.45 KB, patch)
2011-12-27 10:05 PST, Bernd
mats: review+
Details | Diff | Splinter Review

Description Jesse Ruderman 2011-12-12 17:56:27 PST
Created attachment 581129 [details]
testcase

###!!! ASSERTION: vertical damage extends outside table: '(aValue).YMost() <= GetRowCount()', file layout/tables/nsTableFrame.cpp, line 3810
Comment 1 Jesse Ruderman 2011-12-12 17:56:48 PST
Created attachment 581130 [details]
stack trace
Comment 2 Bernd 2011-12-27 10:05:13 PST
Created attachment 584450 [details] [diff] [review]
patch
Comment 4 Bernd 2011-12-27 23:14:54 PST
review hint
http://mxr.mozilla.org/mozilla-central/source/layout/tables/nsCellMap.cpp#2150

we need both the colspan and the rowspan as effective (aka in real cellmap coordinates)

this code is from http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/tables/nsCellMap.cpp&rev=3.44
Comment 5 Mats Palmgren (:mats) 2011-12-28 05:32:24 PST
Bernd, did you intend to ask me to review this patch?
Comment 6 Bernd 2011-12-28 12:43:17 PST
Comment on attachment 584450 [details] [diff] [review]
patch

Yes, the problem is old but currently its the only remainder of the damagearea patch.
Comment 8 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-12-30 05:06:17 PST
https://hg.mozilla.org/mozilla-central/rev/92efb7a05df5

Note You need to log in before you can comment on or make changes to this bug.