Native Fennec crashes when panning

RESOLVED DUPLICATE of bug 710393

Status

()

--
critical
RESOLVED DUPLICATE of bug 710393
7 years ago
7 years ago

People

(Reporter: csuciu, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Comment hidden (empty)
(Reporter)

Comment 1

7 years ago
Build Mozilla/5.0(Android;Linux armv7l; rv:11.0a1)Gecko/20111213 Firefox/11.0a1 Fennec/11.0a1
Device: HTC Desire, Android 2.2

The application is crashing when trying to pan on any page (about:home, about:fennec, www.yahoo.com....etc )
Reproducible also on LG Optimus2x, Android 2.2 

Previously another crashed occurred when updating from yesterday's build (bug #704496)
No crash report submitted

Doesn't seem to be reproducible on Htc Desire Z, Android 2.3; Samsung Nexus S, Android 2.3.6.
(Reporter)

Comment 2

7 years ago
Created attachment 581249 [details]
aLog
Unfortunately, I don't see any crash in the log. Did you capture enough of the log?
(Reporter)

Comment 4

7 years ago
Created attachment 581253 [details]
Log from HTC Desire Android 2.2

Hopefully this is more use useful.
STR
1. Start Fennec
2. Drag finger on about home

I can crash my HTC G2 as well doing this, same hardware as the Desire Z.

All I see that is useful in my logcat is.

I/GeckoPanZoomController(16469): Breaking axis lock at 41.46242909826929 degrees
D/AndroidRuntime(16469): Shutting down VM
W/dalvikvm(16469): threadid=1: thread exiting with uncaught exception (group=0x4001d7e0)

Updated

7 years ago
Severity: normal → critical
Keywords: crash
(In reply to Catalin Suciu from comment #4)
> Created attachment 581253 [details]

This shows:

I/dalvikvm( 2639): Could not find method java.lang.Math.copySign, referenced from method org.mozilla.gecko.ui.PanZoomController$Axis.advanceFling
W/dalvikvm( 2639): VFY: unable to resolve static method 692: Ljava/lang/Math;.copySign (FF)F
D/dalvikvm( 2639): VFY: replacing opcode 0x71 at 0x002d
D/dalvikvm( 2639): VFY: dead code 0x0030-0046 in Lorg/mozilla/gecko/ui/PanZoomController$Axis;.advanceFling ()V

This appears to be the same problem as bug 710393.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 710393
You need to log in before you can comment on or make changes to this bug.