Nightly has violated its self-enforced StrictMode policy after a clean install

VERIFIED FIXED

Status

()

Firefox for Android
General
--
major
VERIFIED FIXED
6 years ago
a year ago

People

(Reporter: xti, Assigned: blassey)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 581248 [details]
screenshot

Mozilla/5.0 (Android;Linux armv7l;rv:11.0a1)Gecko/20111213
Firefox/11.0a1 Fennec/11.0a1
Devices: Motorola Droid PRO
OS: Android 2.3.3

Steps to reproduce:
1. Install the Nightly build since 12/13 (perform a clean install)
2. Open Fennec
3. Go to about:fennec
4. Tap on device Back button

Expected result:
No error/warning popup should occur after steps 2-4.

Actual result:
Since step 2, the following message is displayed for several times after each step: "The application Nightly (process org.mozilla.fennec) has violated its self-enforced StrictMode policy)." [OK]
Chris - Do we expect dialog popups with StrictMode violations? I haven't seen this previously.
Created attachment 581271 [details] [diff] [review]
patch
Assignee: nobody → blassey.bugs
Attachment #581271 - Flags: review?(mark.finkle)
Attachment #581271 - Flags: review?(mark.finkle) → review+

Comment 3

6 years ago
I just got this too.  If it helps

1) for some reason, after restarting post-crash, about:firefox won't load
2) crash report
1e5188a6-9323-41d0-85df-101d62111213
My patch had enabled warning dialogs StrictMode violations, but I had not run into any dialogs in my local testing. Sorry!
https://hg.mozilla.org/mozilla-central/rev/5ae946cbde55
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Verified fixed on:
Fennec Nightly 13.0a1 (2012-02-14)
Device: Motorola Droid PRO (Android 2.3.3)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.