Last Comment Bug 710246 - Investigate substantial increase in libxul size since Gecko 10
: Investigate substantial increase in libxul size since Gecko 10
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Ed Morley [:emorley]
:
Mentors:
Depends on:
Blocks: 709193 750661
  Show dependency treegraph
 
Reported: 2011-12-13 09:03 PST by Kyle Huey [:khuey] (khuey@mozilla.com)
Modified: 2012-05-01 04:21 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
map.py (1.27 KB, text/x-python)
2011-12-13 10:34 PST, Mike Hommey [:glandium]
no flags Details
xul.dll filesizes since 1st Nov (1.96 KB, application/vnd.ms-excel)
2011-12-13 11:11 PST, Ed Morley [:emorley]
no flags Details

Description Kyle Huey [:khuey] (khuey@mozilla.com) 2011-12-13 09:03:06 PST
Firefox 9b5: xul.dll is 15,719 KB
Firefox 10.0a2: xul.dll is 15,724 KB
Firefox 11.0a1 (12/13): xul.dll is 16,115 KB
Comment 1 Mike Hommey [:glandium] 2011-12-13 09:20:17 PST
This applies to linux i686 as well, so it most probably is cross platform.
Firefox 9.0b5: libxul.so is 22,082,596 B
Firefox 10.0a2: libxul.so is 22,231,412 B
Firefox 11.0a1: libxul.so is 22,587,112 B

(and FWIW, Firefox 8.0's is 21,545,036 B)
Comment 2 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-12-13 09:21:33 PST
The difference between 8 and 9 is probably TI, but I can't think of anything we've landed in this cycle that's big ...
Comment 3 Mike Hommey [:glandium] 2011-12-13 10:34:36 PST
Created attachment 581323 [details]
map.py

Here is a script that I wrote a while ago that could be helpful to identify where code size comes from. It takes as input a map file as GNU ld outputs them. You need to add -Wl,-Map,/some/file to the libxul.so link command line, and then run the script against that file. It will output size per section per file with the format "section(file) size" for .text, .data* and .rodata sections. File names are relative to objdir/toolkit/library. What I wanted to do with this output is to create an interactive treemap, but I never found the time.
Comment 4 Ed Morley [:emorley] 2011-12-13 11:11:44 PST
Created attachment 581336 [details]
xul.dll filesizes since 1st Nov

CSV of xul.dll filesizes for each mozilla-central win32 nightly since 1st Nov.

Would appear the main increase is:
2011-11-17-03-09-39 -> 2011-11-18-03-10-05
...which added 284KB bytes (the next highest increase is only 32KB).

This equates to:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=30161b298513&tochange=447556784745
Comment 5 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-12-13 11:12:28 PST
Ah, Skia.

Note You need to log in before you can comment on or make changes to this bug.