Intermittent Android TEST-UNEXPECTED-ERROR | | Exception caught while running tests.

RESOLVED DUPLICATE of bug 687098

Status

Testing
General
RESOLVED DUPLICATE of bug 687098
6 years ago
5 years ago

People

(Reporter: mbrubeck, Unassigned)

Tracking

({intermittent-failure})

11 Branch
ARM
Android
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [test which aborts the suite][tegra][android_tier_1])

(Reporter)

Description

6 years ago
I've seen this before but there doesn't seem to be a bug open:

https://tbpl.mozilla.org/php/getParsedLog.php?id=7907666&tree=Firefox
Android XUL Tegra 250 mozilla-central opt test browser-chrome on 2011-12-13 10:05:17 PST for push 317182c27445

builder: mozilla-central_tegra_android-xul_test-browser-chrome
slave: tegra-091
starttime: 1323799517.44
results: warnings (1)
buildid: 20111213094019
builduid: b7404d3ff8ef44fdbf3d6441dac1832a
revision: 317182c27445

========= Started 'python mochitest/runtestsremote.py ...' warnings (results: 1, elapsed: 1 mins, 47 secs) ==========
python mochitest/runtestsremote.py --deviceIP 10.250.49.79 --xre-path ../hostutils/xre --utility-path ../hostutils/bin --certificate-path certs --app org.mozilla.fennec --console-level INFO --http-port 30091 --ssl-port 31091 --pidfile /builds/tegra-091/test/../runtestsremote.pid --browser-chrome --test-path mobile --symbols-path=../symbols
 in dir /builds/tegra-091/test/build/tests (timeout 2400 secs)
 watching logfiles {}
 argv: ['python', 'mochitest/runtestsremote.py', '--deviceIP', '10.250.49.79', '--xre-path', '../hostutils/xre', '--utility-path', '../hostutils/bin', '--certificate-path', 'certs', '--app', 'org.mozilla.fennec', '--console-level', 'INFO', '--http-port', '30091', '--ssl-port', '31091', '--pidfile', '/builds/tegra-091/test/../runtestsremote.pid', '--browser-chrome', '--test-path', 'mobile', '--symbols-path=../symbols']
 environment:
  MINIDUMP_SAVE_PATH=/builds/tegra-091/test/minidumps
  MINIDUMP_STACKWALK=/builds/tegra-091/test/tools/breakpad/osx/minidump_stackwalk
  PATH=/opt/local/bin:/opt/local/sbin:/opt/local/Library/Frameworks/Python.framework/Versions/2.6/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin
  PWD=/builds/tegra-091/test/build/tests
  SUT_IP=10.250.49.79
  SUT_NAME=tegra-091
  __CF_USER_TEXT_ENCODING=0x1F6:0:0
 closing stdin
 using PTY: False
unable to execute ADB: ensure Android SDK is installed and adb is in your $PATH
restarting as root failed
reconnecting socket
INFO | runtests.py | Installing extension at /builds/tegra-091/test/build/tests/mochitest/extensions/specialpowers to /tmp/tmppUlKUJ.
INFO | runtests.py | Installing extension at /builds/tegra-091/test/build/tests/mochitest/extensions/worker to /tmp/tmppUlKUJ.
INFO | runtests.py | Installing extension at /builds/tegra-091/test/build/tests/mochitest/extensions/workerbootstrap to /tmp/tmppUlKUJ.
pushing directory: /tmp/tmppUlKUJ to /mnt/sdcard/tests/profile
args: ['/builds/tegra-091/test/build/hostutils/bin/xpcshell', '-g', '/builds/tegra-091/test/build/hostutils/xre', '-v', '170', '-f', './httpd.js', '-e', "const _PROFILE_PATH = '/tmp/tmpx_6v9b';const _SERVER_PORT = '30091'; const _SERVER_ADDR ='10.250.48.211';", '-f', './server.js']
INFO | runtests.py | Server pid: 72213
uncaught exception: 2147746065
Timed out while waiting for server startup.
TEST-UNEXPECTED-ERROR | | Exception caught while running tests.
program finished with exit code 1
elapsedTime=107.431219
TinderboxPrint: mochitest-browser-chrome<br/>
Unknown Error: command finished with exit code: 1
======== Finished 'python mochitest/runtestsremote.py ...' warnings (results: 1, elapsed: 1 mins, 47 secs) ========
(Reporter)

Comment 1

6 years ago
Actually, let's move this to testing since the exception is apparently happening in the test runner.
Component: General → General
Product: Fennec → Testing
QA Contact: general → general
Version: Firefox 11 → 11 Branch
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 687098
(Assignee)

Updated

5 years ago
Keywords: intermittent-failure
(Assignee)

Updated

5 years ago
Whiteboard: [orange][test which aborts the suite][tegra][android_tier_1] → [test which aborts the suite][tegra][android_tier_1]
You need to log in before you can comment on or make changes to this bug.