Closed Bug 710302 Opened 8 years ago Closed 8 years ago

going to about: pages does a "feeling lucky" search

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED

People

(Reporter: jbecerra, Assigned: mbrubeck)

References

Details

(Keywords: regression)

Attachments

(1 file, 3 obsolete files)

Using the latest nightly when I go to about: I get a google search results for "about:" instead of the usual about page.

Steps:
1. Install the latest nightly
2. Enter about: in the location field and enter

Expected: about: page showing me information about the build and so on

Actual: Google search results page 

I haven't looked for a regression.
Keywords: regression
OS: Mac OS X → Android
Hardware: x86 → ARM
Attached patch bustage fix for various schemes (obsolete) — Splinter Review
The was regressed by bug 701374. This patch adds checks for various known schemes. Tested and it fixes the issue.

I could try to just use some test for the colon, but this seems more straight forward.
Assignee: nobody → mark.finkle
Attachment #581435 - Flags: review?(mbrubeck)
Comment on attachment 581435 [details] [diff] [review]
bustage fix for various schemes

Maintaining a list of valid URI schemes feel too likely to break in unforseen cases.  ("chrome:" and "jar:" are already missing.)  I'd rather treat any string that contains a colon (without a space preceding it) as a URI.
Attachment #581435 - Flags: review?(mbrubeck) → review-
Attached patch simpler fix (obsolete) — Splinter Review
This version uses the "if a colon exists && before a space" logic

Also fixes the problem
Attachment #581445 - Flags: review?(mbrubeck)
Attached patch even simpler fix (obsolete) — Splinter Review
I think this is equivalent, and even simpler.
Attachment #581448 - Flags: review?(mark.finkle)
Comment on attachment 581448 [details] [diff] [review]
even simpler fix

Works for me
Attachment #581448 - Flags: review?(mark.finkle) → review+
Attachment #581445 - Attachment is obsolete: true
Attachment #581445 - Flags: review?(mbrubeck)
Assignee: mark.finkle → mbrubeck
Attachment #581435 - Attachment is obsolete: true
Attachment #581448 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Verified fixed on the latest fennec native build:
Mozilla /5.0 (Android;Linux armv7l;rv:11.0a1) Gecko/20111214 Firefox/11.0a1 Fennec/11.0a1 
Device: HTC Desire (Android 2.2)
Status: RESOLVED → VERIFIED
Duplicate of this bug: 710744
You need to log in before you can comment on or make changes to this bug.